summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/kyotocabinet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/Manifest1
-rw-r--r--dev-db/kyotocabinet/files/fix_configure-1.2.62.patch51
-rw-r--r--dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch44
-rw-r--r--dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch31
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.76-r1.ebuild57
-rw-r--r--dev-db/kyotocabinet/metadata.xml13
6 files changed, 197 insertions, 0 deletions
diff --git a/dev-db/kyotocabinet/Manifest b/dev-db/kyotocabinet/Manifest
new file mode 100644
index 000000000000..1a8124d6b967
--- /dev/null
+++ b/dev-db/kyotocabinet/Manifest
@@ -0,0 +1 @@
+DIST kyotocabinet-1.2.76.tar.gz 951930 SHA256 812a2d3f29c351db4c6f1ff29d94d7135f9e601d7cc1872ec1d7eed381d0d23c SHA512 278db7b327eb4c21bf0137d9aa14fb67d74d5ce7ed1cb29fc9120d157a60de165ec0cf842903eb7952e8f998045ae585b958977fa973ba0e0773381de71d9f6a WHIRLPOOL db984a6dcef0e3f313e56e5398a0fe75d1014e02dce04c4837d0aa01c0e97eb04eac728f4e9b600acec22a098a1f19ba33d8abb2ee50a8a60ba64afcd6d9c873
diff --git a/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch b/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch
new file mode 100644
index 000000000000..622b7fd52792
--- /dev/null
+++ b/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch
@@ -0,0 +1,51 @@
+diff --git a/configure.in b/configure.in
+index 94e9d29..6999615 100644
+--- a/configure.in
++++ b/configure.in
+@@ -35,27 +35,18 @@ MYDOCUMENTFILES="COPYING FOSSEXCEPTION ChangeLog doc kyotocabinet.idl"
+ MYPCFILES="kyotocabinet.pc"
+
+ # Building flags
+-MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char -g0 -O2"
+-MYCXXFLAGS="-Wall -fPIC -fsigned-char -g0 -O2"
+-MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I/usr/local/include"
++MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char"
++MYCXXFLAGS="-Wall -fPIC -fsigned-char"
++MYCPPFLAGS="-I. -I\$(INCLUDEDIR)"
+ MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1"
+ MYCPPFLAGS="$MYCPPFLAGS -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D__EXTENSIONS__"
+-MYLDFLAGS="-L. -L\$(LIBDIR) -L/usr/local/lib"
++MYLDFLAGS="-L. -L\$(LIBDIR)"
+ MYCMDLDFLAGS=""
+ MYCMDLIBS=""
+ MYLDLIBPATH=""
+ MYLDLIBPATHENV="LD_LIBRARY_PATH"
+ MYPOSTCMD="true"
+
+-# Building paths
+-PATH=".:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:$PATH"
+-CPATH=".:/usr/local/include:$CPATH"
+-LIBRARY_PATH=".:/usr/local/lib:$LIBRARY_PATH"
+-LD_LIBRARY_PATH=".:/usr/local/lib:$LD_LIBRARY_PATH"
+-PKG_CONFIG_PATH=".:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
+-export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
+-
+-
+
+ #================================================================
+ # Options
+@@ -285,14 +276,6 @@ then
+ MYCMDLIBS="$MYCMDLIBS $LIBS"
+ fi
+
+-# As-needed linking
+-if uname | grep Linux >config.tmp
+-then
+- MYLDFLAGS="$MYLDFLAGS -Wl,-rpath-link,.:/usr/local/lib:$MYLDLIBPATH"
+- MYLDFLAGS="$MYLDFLAGS -Wl,--as-needed"
+-else
+- MYCMDLIBS="$MYCMDLIBS $LIBS"
+-fi
+
+ # Shared libraries
+ if test "$enable_shared" != "no" && test "$enable_profile" != "yes"
diff --git a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch
new file mode 100644
index 000000000000..729efc083ba5
--- /dev/null
+++ b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-configure-8-byte-atomics.patch
@@ -0,0 +1,44 @@
+From: Shawn Landden <shawnlandden@gmail.com>
+Date: Thu, 21 Jun 2012 20:34:28 -0700
+Subject: configure: 8 byte atomics
+
+fix up configure test to handle lack of 8 byte atomics correctly
+
+as is the case with all ARM targets currently
+---
+ configure | 29 +++++++++++++----------------
+ configure.in | 19 ++++++++++++++++---
+ 2 files changed, 29 insertions(+), 19 deletions(-)
+
+index a07063d..bfc6df0 100755
+--- a/configure.in
++++ b/configure.in
+@@ -238,9 +238,22 @@ fi
+ # Atomic operations
+ if test "$enable_atomic" != "no"
+ then
+- printf 'checking for atomic operations... '
+- AC_TRY_COMPILE([], [__sync_fetch_and_add], [MYGCCATOMIC=yes], [MYGCCATOMIC=no])
+- if test "$MYGCCATOMIC" = "yes"
++ printf 'checking for 8 byte atomic operations... '
++ if printf '
++/* Some targets support 4 byte atomics, but not 8 byte atomics,
++ * and will fail at link time if they are used.
++ *
++ * http://gcc.gnu.org/onlinedocs/gcc-4.6.3/gcc/Atomic-Builtins.html
++ * http://gcc.gnu.org/wiki/Atomic
++ */
++#include <stdint.h>
++int
++main ()
++{
++uint64_t n = 0xdeadbeaf;
++__sync_bool_compare_and_swap(&n, 0xdeadbeaf, 0);
++return n;
++}' | $CC -xc -o config.tmp - >/dev/null 2>&1
+ then
+ MYCPPFLAGS="$MYCPPFLAGS -D_MYGCCATOMIC"
+ printf 'yes\n'
+--
+1.7.9.5
+
diff --git a/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch
new file mode 100644
index 000000000000..931e8c3f7bbe
--- /dev/null
+++ b/dev-db/kyotocabinet/files/kyotocabinet-1.2.76-flags.patch
@@ -0,0 +1,31 @@
+--- a/configure.in
++++ b/configure.in
+@@ -193,28 +193,6 @@
+ # Byte order
+ AC_C_BIGENDIAN(MYCPPFLAGS="$MYCPPFLAGS -D_MYBIGEND")
+
+-# System-depending optimization
+-printf 'checking for 64-bit availability... '
+-if printf 'main() {}' | $CC -xc -m64 -o config.tmp - >config.tmp 2>&1
+-then
+- MYCFLAGS="-m64 $MYCFLAGS"
+- MYCXXFLAGS="-m64 $MYCXXFLAGS"
+- printf 'yes\n'
+-else
+- printf 'no\n'
+-fi
+-if test "$enable_opt" != "no"
+-then
+- printf 'checking for CPU optimization availability... '
+- if printf 'main() {}' | $CC -xc -march=native -o config.tmp - >config.tmp 2>&1
+- then
+- MYCFLAGS="-march=native $MYCFLAGS"
+- MYCXXFLAGS="-march=native $MYCXXFLAGS"
+- printf 'yes\n'
+- else
+- printf 'no\n'
+- fi
+-fi
+ printf 'checking for useless warnings... '
+ if printf 'main() {}' | $CC -xc \
+ -Wno-unused-but-set-variable -Wno-unused-but-set-parameter -o config.tmp - >config.tmp 2>&1
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.76-r1.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.76-r1.ebuild
new file mode 100644
index 000000000000..ea29c3c6f97f
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.76-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples static-libs"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix_configure-1.2.62.patch
+ epatch "${FILESDIR}"/${PN}-1.2.76-configure-8-byte-atomics.patch
+ epatch "${FILESDIR}"/${PN}-1.2.76-flags.patch
+ sed -i -e "/DOCDIR/d" Makefile.in || die
+ tc-export AR
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable !static-libs shared) \
+ --enable-lzma --docdir=/usr/share/doc/${PF}
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ prune_libtool_files
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/*
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/*
+ fi
+}
diff --git a/dev-db/kyotocabinet/metadata.xml b/dev-db/kyotocabinet/metadata.xml
new file mode 100644
index 000000000000..35319898fd0a
--- /dev/null
+++ b/dev-db/kyotocabinet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ </maintainer>
+</pkgmetadata>