summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/lib_mysqludf_ta
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/lib_mysqludf_ta')
-rw-r--r--dev-db/lib_mysqludf_ta/Manifest1
-rw-r--r--dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild68
-rw-r--r--dev-db/lib_mysqludf_ta/metadata.xml10
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_ta/Manifest b/dev-db/lib_mysqludf_ta/Manifest
new file mode 100644
index 000000000000..df37fbf1cbea
--- /dev/null
+++ b/dev-db/lib_mysqludf_ta/Manifest
@@ -0,0 +1 @@
+DIST joaocosta-lib_mysqludf_ta-a8e623c.tar.gz 932876 SHA256 6f1b728018f1bae276ce6d6722263fa07c8a864752b8906a030e3830e6321069 SHA512 4e8422067a055b55bdd1e7103f925f47b8174a83bd20d337d3f39479eebba3de9da0dc8a382441c090c6ef86b03e965d34a38b4c0f3ecc14ad0408aa2cdf511a WHIRLPOOL a4b6b644d01ca23708166307533ae5ea3b26da70728c1a08d2fb1f74b28d567c5a724ce1b036d82c80e5591247addcfed1e554ebfba33e0b69e47d0017b6e08b
diff --git a/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild b/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild
new file mode 100644
index 000000000000..c369e882397f
--- /dev/null
+++ b/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+MY_REV="a8e623c" # checkout revision
+MY_USR="joaocosta" # user name
+
+MY_P="${MY_USR}-${PN}-${MY_REV}"
+
+DESCRIPTION="MySQL UDFs with technical analysis functions"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_ta/"
+SRC_URI="https://github.com/${MY_USR}/${PN}/tarball/${MY_REV} -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+
+ # fix Makefile.am
+ sed -i -e "s|\(-shared\)|\1 -avoid-version|g" Makefile.am
+
+ # convert to UTF-8
+ iconv -f LATIN1 -t UTF-8 < README > README~
+ mv -f README~ README
+
+ edos2unix README
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README sampledb.sql
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_ta/metadata.xml b/dev-db/lib_mysqludf_ta/metadata.xml
new file mode 100644
index 000000000000..4ac18c38ace4
--- /dev/null
+++ b/dev-db/lib_mysqludf_ta/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">joaocosta/lib_mysqludf_ta</remote-id>
+ </upstream>
+</pkgmetadata>