summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-02 19:12:05 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-02 19:18:34 -0400
commit1632e2115f726b6e668aca48915f2b83e662325b (patch)
treea43077bd46f758170f89400acbaa1dedacce7d5c /dev-db/libiodbc/libiodbc-3.52.12.ebuild
parentdev-perl/Test-NoWarnings: Weaken dependency on dev-perl/Test-Tester (diff)
downloadgentoo-1632e2115f726b6e668aca48915f2b83e662325b.tar.gz
gentoo-1632e2115f726b6e668aca48915f2b83e662325b.tar.bz2
gentoo-1632e2115f726b6e668aca48915f2b83e662325b.zip
dev-db/libiodbc: new version 3.5.12.
This new version comes with a few changes. Most noticeably, the ebuild was updated to EAPI=6 and the eutils eclass was dropped. One patch (fix-runpaths-r1.patch) had to be revisioned to make it compatible with eapply. Another patch, libiodbc-*-multilib.patch, had to be updated to apply to the new version. I duplicated the additions/deletions in the original patch exactly. Two other patches, libiodbc-3.52.7-gtk.patch and libiodbc-3.52.8-gtk-parallel-make.patch, have become obsolete and were removed completely. I removed a "chmod -x include/*.h" hack, as it looks no longer necessary. I then added a new hack, "touch ChangeLog" before eautoreconf. Gentoo-Bug: 516300 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-db/libiodbc/libiodbc-3.52.12.ebuild')
-rw-r--r--dev-db/libiodbc/libiodbc-3.52.12.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/libiodbc/libiodbc-3.52.12.ebuild b/dev-db/libiodbc/libiodbc-3.52.12.ebuild
new file mode 100644
index 000000000000..7ae7799fe1ab
--- /dev/null
+++ b/dev-db/libiodbc/libiodbc-3.52.12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+MY_PN="iODBC"
+
+DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.iodbc.org/"
+SRC_URI="https://github.com/openlink/${MY_PN}/archive/v${PV}.zip -> ${P}.zip"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="|| ( LGPL-2 BSD )"
+SLOT="0"
+IUSE="gtk"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/iodbc-config )
+
+PATCHES=(
+ "${FILESDIR}"/libiodbc-3.52.12-multilib.patch
+ "${FILESDIR}"/libiodbc-3.52.7-debian_bug501100.patch
+ "${FILESDIR}"/libiodbc-3.52.7-debian_bug508480.patch
+ "${FILESDIR}"/libiodbc-3.52.7-unicode_includes.patch
+ "${FILESDIR}"/fix-runpaths-r1.patch
+)
+
+src_prepare() {
+ default
+ sed -i.orig \
+ -e '/^cd "$PREFIX"/,/^esac/d' \
+ iodbc/install_libodbc.sh || die "sed failed"
+
+ # Without this, automake dies. It's what upstream's autogen.sh does.
+ touch ChangeLog || die "failed to create empty ChangeLog"
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-static \
+ --enable-odbc3 \
+ --enable-pthreads \
+ --with-layout=gentoo \
+ --with-iodbc-inidir=yes \
+ $(use_enable gtk gui)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+
+ # Install lintian overrides
+ insinto /usr/share/lintian/overrides
+ newins debian/iodbc.lintian-overrides iodbc
+ newins debian/libiodbc2.lintian-overrides libiodbc2
+}