summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-08-23 14:42:44 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2021-08-23 17:40:29 +0200
commitbf8e03756852ba2705bf5259b590edaca8d271ad (patch)
tree90472867608a48130a21f3126c5df45c9dbb7738 /dev-db/mongodb
parentdev-libs/libgudev: skip test-double when fr_FR.UTF-8 is missing (diff)
downloadgentoo-bf8e03756852ba2705bf5259b590edaca8d271ad.tar.gz
gentoo-bf8e03756852ba2705bf5259b590edaca8d271ad.tar.bz2
gentoo-bf8e03756852ba2705bf5259b590edaca8d271ad.zip
dev-db/mongodb: require AVX for mongodb-5.0
Closes: https://bugs.gentoo.org/809692 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22079 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
Diffstat (limited to 'dev-db/mongodb')
-rw-r--r--dev-db/mongodb/mongodb-5.0.2.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-db/mongodb/mongodb-5.0.2.ebuild b/dev-db/mongodb/mongodb-5.0.2.ebuild
index 03eb379258b4..a2ee4340b7f1 100644
--- a/dev-db/mongodb/mongodb-5.0.2.ebuild
+++ b/dev-db/mongodb/mongodb-5.0.2.ebuild
@@ -21,7 +21,8 @@ SRC_URI="https://fastdl.mongodb.org/src/${MY_P}.tar.gz"
LICENSE="Apache-2.0 SSPL-1"
SLOT="0"
KEYWORDS="~amd64 ~arm64 -riscv"
-IUSE="debug kerberos lto mongosh ssl +tools"
+CPU_FLAGS="cpu_flags_x86_avx"
+IUSE="debug kerberos lto mongosh ssl +tools ${CPU_FLAGS}"
# https://github.com/mongodb/mongo/wiki/Test-The-Mongodb-Server
# resmoke needs python packages not yet present in Gentoo
@@ -77,6 +78,13 @@ python_check_deps() {
}
pkg_pretend() {
+ # Bug 809692
+ if ! use cpu_flags_x86_avx; then
+ eerror "MongoDB 5.0 requires use of the AVX instruction set"
+ eerror "https://docs.mongodb.com/v5.0/administration/production-notes/"
+ die "MongoDB requires AVX"
+ fi
+
if [[ -n ${REPLACING_VERSIONS} ]]; then
if ver_test "$REPLACING_VERSIONS" -lt 4.4; then
ewarn "To upgrade from a version earlier than the 4.4-series, you must"