summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-10-25 17:07:43 +0200
committerAmy Liffey <amynka@gentoo.org>2017-10-25 20:48:40 +0200
commit772b80658ebe20d659319d68d521254725e37a13 (patch)
treeb8302b2609312e25ec27540e7b765bdd2d21b4ee /dev-db/mydumper/mydumper-0.9.3-r1.ebuild
parentdev-perl/Sys-CpuLoad: Add w/ version 0.30.0 (diff)
downloadgentoo-772b80658ebe20d659319d68d521254725e37a13.tar.gz
gentoo-772b80658ebe20d659319d68d521254725e37a13.tar.bz2
gentoo-772b80658ebe20d659319d68d521254725e37a13.zip
dev-db/mydumper: do not use mariadb server headers (bug #635176)
Closes: #6049 Closes: https://bugs.gentoo.org/635176 Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'dev-db/mydumper/mydumper-0.9.3-r1.ebuild')
-rw-r--r--dev-db/mydumper/mydumper-0.9.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-db/mydumper/mydumper-0.9.3-r1.ebuild b/dev-db/mydumper/mydumper-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..f95deef1be62
--- /dev/null
+++ b/dev-db/mydumper/mydumper-0.9.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL"
+HOMEPAGE="https://github.com/maxbube/mydumper"
+SRC_URI="https://github.com/maxbube/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+CDEPEND="dev-libs/glib:=
+ dev-libs/libpcre:=
+ dev-libs/openssl:=
+ sys-libs/zlib:=
+ virtual/mysql"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-mariadb-define.patch" )
+
+src_prepare() {
+ # respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
+ sed -i -e 's:-Werror -O3 -g:${CMAKE_C_FLAGS}:' CMakeLists.txt || die
+
+ # fix doc install path
+ sed -i -e "s:share/doc/mydumper:share/doc/${PF}:" docs/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=("-DBUILD_DOCS=$(usex doc)")
+
+ cmake-utils_src_configure
+}