summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-06 20:49:20 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-06 20:50:24 +0100
commit98a62031a548747cb66a8f6a5b24dc065aa8d8ac (patch)
tree433ba828c26879ee7607295ff6f54e00613670df /dev-db/mysql-connector-c++/mysql-connector-c++-8.0.13.ebuild
parentmedia-gfx/imagemagick: drop old (diff)
downloadgentoo-98a62031a548747cb66a8f6a5b24dc065aa8d8ac.tar.gz
gentoo-98a62031a548747cb66a8f6a5b24dc065aa8d8ac.tar.bz2
gentoo-98a62031a548747cb66a8f6a5b24dc065aa8d8ac.zip
dev-db/mysql-connector-c++: bump to v1.1.11 & v8.0.13
Bug: https://bugs.gentoo.org/674450 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mysql-connector-c++/mysql-connector-c++-8.0.13.ebuild')
-rw-r--r--dev-db/mysql-connector-c++/mysql-connector-c++-8.0.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.13.ebuild b/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.13.ebuild
new file mode 100644
index 000000000000..f823bf40e1c4
--- /dev/null
+++ b/dev-db/mysql-connector-c++/mysql-connector-c++-8.0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake-utils
+
+DESCRIPTION="MySQL database connector for C++ (mimics JDBC 4.0 API)"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/cpp/"
+URI_DIR="Connector-C++"
+SRC_URI="https://dev.mysql.com/get/Downloads/${URI_DIR}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+legacy"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-libs/protobuf:=
+ legacy? (
+ dev-libs/boost:=
+ >=dev-db/mysql-connector-c-6.1.8:=
+ )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-8.0.13-fix-build.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_SSL=system
+ -DWITH_JDBC=$(usex legacy ON OFF)
+ )
+
+ cmake-utils_src_configure
+}