summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/mysql-super-smack/mysql-super-smack-1.3-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/mysql-super-smack/mysql-super-smack-1.3-r3.ebuild')
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3-r3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3-r3.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r3.ebuild
new file mode 100644
index 000000000000..bd1fc8638faf
--- /dev/null
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WANT_AUTOMAKE="1.13"
+AUTOTOOLS_AUTORECONF="YES"
+#AUTOTOOLS_IN_SOURCE_BUILD="YES"
+
+inherit eutils autotools-utils
+
+MY_PN="super-smack"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
+HOMEPAGE="http://vegan.net/tony/supersmack/"
+SRC_URI="http://vegan.net/tony/supersmack/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="+mysql postgres"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.destdir.patch
+ "${FILESDIR}"/${PN}-1.3.amd64.patch
+ "${FILESDIR}"/${PN}-1.3.gcc4.3.patch
+ "${FILESDIR}"/${PN}-1.3-gen-data.patch
+ "${FILESDIR}"/${PN}-1.3-automake-1.13.patch
+)
+DOCS=( CHANGES INSTALL MANUAL README TUTORIAL )
+
+src_prepare() {
+ # Clean up files so eautoreconf does not pick up any
+ # deprecated autotools macros.
+ rm acinclude.m4 aclocal.m4 acconfig.h config.status config.h || die
+ mv configure.in configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(usex mysql --with-mysql "")
+ $(usex postgres --with-pgsql "")
+ --with-datadir=/var/tmp/${MY_PN}
+ --with-smacks-dir=/usr/share/${MY_PN}
+ )
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "The gen-data binary is now installed as super-smack-gen-data"
+}