summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-07-28 23:20:47 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-07-31 21:59:15 +0300
commitba9322f36ca48d07c585029b6b5d0c6b8cefb76c (patch)
tree1bb9b82fd5e4a9619c979c9615d48c5fa09d01a8 /dev-db/mysqltuner
parentdev-ruby/dotenv: add 2.7.5 (diff)
downloadgentoo-ba9322f36ca48d07c585029b6b5d0c6b8cefb76c.tar.gz
gentoo-ba9322f36ca48d07c585029b6b5d0c6b8cefb76c.tar.bz2
gentoo-ba9322f36ca48d07c585029b6b5d0c6b8cefb76c.zip
dev-db/mysqltuner: bump to 1.7.15
Version bump to 1.7.15. Also introduces new patch that fixes password detecting error. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://github.com/gentoo/gentoo/pull/12565 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/mysqltuner')
-rw-r--r--dev-db/mysqltuner/Manifest1
-rw-r--r--dev-db/mysqltuner/files/mysqltuner-1.7.15-password.patch11
-rw-r--r--dev-db/mysqltuner/mysqltuner-1.7.15.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-db/mysqltuner/Manifest b/dev-db/mysqltuner/Manifest
index 63b7acdba735..b25d9096e33c 100644
--- a/dev-db/mysqltuner/Manifest
+++ b/dev-db/mysqltuner/Manifest
@@ -1,2 +1,3 @@
DIST mysqltuner-1.6.18.tar.gz 169074 BLAKE2B e138e29db2f0b1abf88b2d8268732fd9f05043abf320d8d97493d6abb3880e5664eaea39392406297e3125789ffc172f6347922ba14a00af16beb3f6f8080802 SHA512 8067b7ac4a4fe7398ee2cdc463a30042f46972f97680b49912dca46fd1d835989aa4115568dbe5473ff28c4d956bf0ad70537318db788dd56bc93ad220e6bcb6
DIST mysqltuner-1.7.13.tar.gz 26721104 BLAKE2B 76a51c5e3ff897feed6bb6348fb5b09ab3fce0eae403880a3be96203522c9006980dbf6966e8c7e7784168c71e149cc57941ffbadba049b68b30993ed4d519d1 SHA512 88842bef1968f3150be49a5e82cdd0349bf0975f6ff0d8188117240ed2161ae1e44722077ff661ce31b55d0d4fc90fa4bb1972d96405113d82255718cebe0d53
+DIST mysqltuner-1.7.15.tar.gz 212839 BLAKE2B cd90091063e6ae7737cb79f6936d14577352c5b6c016e0efcf82cfcabcbc1acf9f646258bebc835ede368d5ea5594e269d165cb01ab8c980e5fdc68f3c605747 SHA512 b1ea9c91df3fb68d7ae9e54014b4d9095122f10750f7807e0c72d9bbbb859db9a60bc8698d337f4dda6e1bd89ce4ff97fa4299f5dbf650f6fa03012c309e761f
diff --git a/dev-db/mysqltuner/files/mysqltuner-1.7.15-password.patch b/dev-db/mysqltuner/files/mysqltuner-1.7.15-password.patch
new file mode 100644
index 000000000000..3c61c1ed3933
--- /dev/null
+++ b/dev-db/mysqltuner/files/mysqltuner-1.7.15-password.patch
@@ -0,0 +1,11 @@
+--- a/mysqltuner.pl 2019-05-21 21:04:53.000000000 +0300
++++ b/mysqltuner.pl 2019-07-28 22:14:09.888967978 +0300
+@@ -1739,7 +1739,7 @@
+ my $PASS_COLUMN_NAME = 'password';
+ if ( $myvar{'version'} =~ /5\.7|10\..*MariaDB*/ ) {
+ $PASS_COLUMN_NAME =
+-"IF(plugin='mysql_native_password', authentication_string, password)";
++"IF(plugin='mysql_native_password', authentication_string, 'password')";
+ }
+ debugprint "Password column = $PASS_COLUMN_NAME";
+
diff --git a/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild b/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
new file mode 100644
index 000000000000..4d6ffb075a99
--- /dev/null
+++ b/dev-db/mysqltuner/mysqltuner-1.7.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=MySQLTuner-perl
+
+DESCRIPTION="MySQLTuner is a high-performance MySQL tuning script"
+HOMEPAGE="https://github.com/major/MySQLTuner-perl"
+SRC_URI="https://github.com/major/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/mysql
+ virtual/perl-Getopt-Long"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # Fix password detecting under MySQL 5.7 upstream #442 #427 #441
+ "${FILESDIR}/${P}-password.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( USAGE.md CONTRIBUTING.md INTERNALS.md basic_passwords.txt vulnerabilities.csv )
+
+src_install() {
+ einstalldocs
+
+ newbin "${PN}.pl" "${PN}"
+
+ # Passwords and vulnerabilities are meant to be fed
+ # to the script uncompressed.
+ docompress -x "/usr/share/doc/${PF}/basic_passwords.txt" "/usr/share/doc/${PF}/vulnerabilities.csv"
+}