summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <mscardovi@icloud.com>2022-12-28 23:55:48 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-01-20 15:31:08 +0200
commit2a9c4f45fc6972353891852bdade6bbeaf1d175b (patch)
tree9c29225267c42678b10abbc99759d7fee38e131e /dev-db/opendbx
parentapp-shells/zsh-completions: drop 0.33.0 (diff)
downloadgentoo-2a9c4f45fc6972353891852bdade6bbeaf1d175b.tar.gz
gentoo-2a9c4f45fc6972353891852bdade6bbeaf1d175b.tar.bz2
gentoo-2a9c4f45fc6972353891852bdade6bbeaf1d175b.zip
dev-db/opendbx: drop 1.4.5-r2, 1.4.6-r4
Signed-off-by: Marco Scardovi <mscardovi@icloud.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/opendbx')
-rw-r--r--dev-db/opendbx/Manifest1
-rw-r--r--dev-db/opendbx/opendbx-1.4.5-r2.ebuild79
-rw-r--r--dev-db/opendbx/opendbx-1.4.6-r4.ebuild79
3 files changed, 0 insertions, 159 deletions
diff --git a/dev-db/opendbx/Manifest b/dev-db/opendbx/Manifest
index bed49d750703..ef7793e7dda5 100644
--- a/dev-db/opendbx/Manifest
+++ b/dev-db/opendbx/Manifest
@@ -1,3 +1,2 @@
DIST libopendbx-1.5.0.tar.gz 583894 BLAKE2B c427bf8d79df6b83d0ce940d974625bd9b54e49e502f864d244a780185b6321f84a6b779e09b603a71ca26549844001268f0357169e9a74e742b9c2668e4b3ec SHA512 7e4e9b8c62fd981276f6747f8184d7e34d743b866bfd76c8126a16371b50dc682177fd563212333d2dbebe2128d0b1527fc69029833329ba8cc0311308fa9bb5
-DIST opendbx-1.4.5.tar.gz 582915 BLAKE2B 7a11947f73ba3a3d407fecf7600589b64a6a80b82f24720ae613d1dc7044e7efe3af8fe273c0cdb043923af2cee1913766054eff3267243345b89c6977124be6 SHA512 e46289f9a7eb8b6e4084863834f8c4ca080eb3343b5f9d5837c476bab0a39e798a6364c8648f9fb53e52ab60cae57749b9f7e9bd23cb95b8ff21160f1bf4247e
DIST opendbx-1.4.6.tar.gz 587514 BLAKE2B 0a6c983ac1ebdc3ad9390185938f32e13ba9ff2ced6d41390421e1e3a1e9eb639a85d89da7ce2dd67f05fd2fcaebb2f53146f43678e548511403d8cdc4de88da SHA512 dd6d53d29157057dbf4e273fd82c7694e8bc626d3409d6ab9c25627a0fec96418326550fa8004b5341facdc4cd8aae12516224e8bb84e2562482885780ff0e55
diff --git a/dev-db/opendbx/opendbx-1.4.5-r2.ebuild b/dev-db/opendbx/opendbx-1.4.5-r2.ebuild
deleted file mode 100644
index 648c8613b17f..000000000000
--- a/dev-db/opendbx/opendbx-1.4.5-r2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic
-
-DESCRIPTION="OpenDBX - A database abstraction layer"
-HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
-SRC_URI="https://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="firebird +mysql oracle postgres sqlite"
-RESTRICT="firebird? ( bindist )"
-
-RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( dev-db/sqlite:3 )
- oracle? ( dev-db/oracle-instantclient[sdk] )
- firebird? ( dev-db/firebird )"
-DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
-
-REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
-
-PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
-
-pkg_setup() {
- if use oracle && [[ ! -d ${ORACLE_HOME} ]]
- then
- die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
- fi
-}
-
-src_configure() {
- local backends=""
-
- use firebird && backends="${backends} firebird"
- use mysql && backends="${backends} mysql"
- use oracle && backends="${backends} oracle"
- use postgres && backends="${backends} pgsql"
- use sqlite && backends="${backends} sqlite3"
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
-
- if use oracle ; then
- # Traditionally, OCI header files are provided in:
- append-cppflags -I"${ORACLE_HOME}"/rdbms/public
- # But newer versions merged them with additional SDKs:
- append-cppflags -I"${ORACLE_HOME}"/sdk/include
- # Depending on the client package ORACLE_HOME refers to,
- # we need to find the libraries in varying locations:
- # - gentoo instantclient has multilib (dev-db/oracle-instantclient)
- append-ldflags -L"${ORACLE_HOME}"/$(get_libdir)
- # - vanilla full client lacks multilib (LINUX*_client{,_home}.zip)
- append-ldflags -L"${ORACLE_HOME}"/lib
- # - vanilla instantclient lacks libdir (instantclient-*.zip)
- append-ldflags -L"${ORACLE_HOME}"
- fi
-
- # bug #788304
- append-cxxflags -std=c++14
-
- econf --with-backends="${backends}"
-}
-
-src_compile() {
- # bug #322221
- emake -j1
-}
-
-src_install() {
- emake -j1 install DESTDIR="${D}"
- dodoc AUTHORS ChangeLog README
-
- rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
-}
diff --git a/dev-db/opendbx/opendbx-1.4.6-r4.ebuild b/dev-db/opendbx/opendbx-1.4.6-r4.ebuild
deleted file mode 100644
index 0a2385d02aca..000000000000
--- a/dev-db/opendbx/opendbx-1.4.6-r4.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit flag-o-matic
-
-DESCRIPTION="OpenDBX - A database abstraction layer"
-HOMEPAGE="https://www.linuxnetworks.de/doc/index.php/OpenDBX"
-SRC_URI="https://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="firebird +mysql oracle postgres sqlite"
-RESTRICT="firebird? ( bindist )"
-
-RDEPEND="mysql? ( dev-db/mysql-connector-c:0= )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( dev-db/sqlite:3 )
- oracle? ( dev-db/oracle-instantclient[sdk] )
- firebird? ( dev-db/firebird )"
-DEPEND="${RDEPEND} app-doc/doxygen app-text/docbook2X"
-
-REQUIRED_USE="|| ( firebird mysql oracle postgres sqlite )"
-
-PATCHES=( "${FILESDIR}/${PN}-doxy.patch" )
-
-pkg_setup() {
- if use oracle && [[ ! -d ${ORACLE_HOME} ]]
- then
- die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
- fi
-}
-
-src_configure() {
- local backends=""
-
- use firebird && backends="${backends} firebird"
- use mysql && backends="${backends} mysql"
- use oracle && backends="${backends} oracle"
- use postgres && backends="${backends} pgsql"
- use sqlite && backends="${backends} sqlite3"
-
- use mysql && append-cppflags -I/usr/include/mysql
- use firebird && append-cppflags -I/opt/firebird/include
-
- if use oracle ; then
- # Traditionally, OCI header files are provided in:
- append-cppflags -I"${ORACLE_HOME}"/rdbms/public
- # But newer versions merged them with additional SDKs:
- append-cppflags -I"${ORACLE_HOME}"/sdk/include
- # Depending on the client package ORACLE_HOME refers to,
- # we need to find the libraries in varying locations:
- # - gentoo instantclient has multilib (dev-db/oracle-instantclient)
- append-ldflags -L"${ORACLE_HOME}"/$(get_libdir)
- # - vanilla full client lacks multilib (LINUX*_client{,_home}.zip)
- append-ldflags -L"${ORACLE_HOME}"/lib
- # - vanilla instantclient lacks libdir (instantclient-*.zip)
- append-ldflags -L"${ORACLE_HOME}"
- fi
-
- # bug #788304
- append-cxxflags -std=c++14
-
- econf --with-backends="${backends}"
-}
-
-src_compile() {
- # bug #322221
- emake -j1
-}
-
-src_install() {
- emake -j1 install DESTDIR="${D}"
- dodoc AUTHORS ChangeLog README
-
- rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
-}