summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-09-08 15:59:49 +0200
committerAgostino Sarubbo <ago@gentoo.org>2021-09-08 15:59:49 +0200
commit2afee7cf96e4a568c1d96af5b6d52ab027f0017b (patch)
treecd58029661fdc6477de3d88684becffd83d28c4f /dev-db/pg_activity/pg_activity-2.2.1.ebuild
parentlinux-info.eclass : Remove log references to linux 2.4 and gcc 4 (diff)
downloadgentoo-2afee7cf96e4a568c1d96af5b6d52ab027f0017b.tar.gz
gentoo-2afee7cf96e4a568c1d96af5b6d52ab027f0017b.tar.bz2
gentoo-2afee7cf96e4a568c1d96af5b6d52ab027f0017b.zip
dev-db/pg_activity: version bump t 2.2.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db/pg_activity/pg_activity-2.2.1.ebuild')
-rw-r--r--dev-db/pg_activity/pg_activity-2.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-db/pg_activity/pg_activity-2.2.1.ebuild b/dev-db/pg_activity/pg_activity-2.2.1.ebuild
new file mode 100644
index 000000000000..76fc218aadab
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-2.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt and not test_data.py'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}