summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-02-18 14:03:37 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-02-18 14:03:44 -0500
commitcf58dfea3eb65e157aa56bc11cc795b49c629c1c (patch)
tree1c6968036ce49f38579309595799070696a03d6b /dev-db/pgagent/files
parentdev-db/pspg: Bump to 2.6.6 (diff)
downloadgentoo-cf58dfea3eb65e157aa56bc11cc795b49c629c1c.tar.gz
gentoo-cf58dfea3eb65e157aa56bc11cc795b49c629c1c.tar.bz2
gentoo-cf58dfea3eb65e157aa56bc11cc795b49c629c1c.zip
dev-db/pgagent: Fix pthread linking
Bug: https://bugs.gentoo.org/688472 Package-Manager: Portage-2.3.84, Repoman-2.3.16 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgagent/files')
-rw-r--r--dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch b/dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch
new file mode 100644
index 000000000000..95f8e998f58f
--- /dev/null
+++ b/dev-db/pgagent/files/pgagent-4.0.0-pthreads-linking.patch
@@ -0,0 +1,33 @@
+From 5b79460bdda286ca988b39e93e446176e8a781d1 Mon Sep 17 00:00:00 2001
+From: Neel Patel <neel.patel@enterprisedb.com>
+Date: Fri, 20 Jul 2018 13:35:35 +0100
+Subject: [PATCH] Link with pthreads on non-Windows and non-macOS platforms.
+
+Patch based on feedback and initial work by Christoph Berg.
+---
+ CMakeLists.txt | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1be24da..6f1eaa0 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -134,9 +134,15 @@ IF(WIN32)
+ ENDIF(WIN32)
+
+ ADD_EXECUTABLE(pgagent ${_srcs})
++IF(UNIX AND NOT APPLE)
++TARGET_LINK_LIBRARIES(
++ pgagent ${PG_LIBRARIES} ${Boost_LIBRARIES} -pthread
++)
++ELSE()
+ TARGET_LINK_LIBRARIES(
+ pgagent ${PG_LIBRARIES} ${Boost_LIBRARIES}
+ )
++ENDIF()
+
+ # Installation
+ IF (WIN32)
+--
+2.24.1
+