summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2021-03-03 07:52:31 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2021-03-03 07:52:31 -0500
commit071aefbb22ddad3fbd8e905fb334408b442f7e10 (patch)
tree9caea221bb85419985032cec7c586580c9172a51 /dev-db/pgpool2
parentwww-apps/novnc: amd64/x86 stable (ALLARCHES policy) wrt bug #773946 (diff)
downloadgentoo-071aefbb22ddad3fbd8e905fb334408b442f7e10.tar.gz
gentoo-071aefbb22ddad3fbd8e905fb334408b442f7e10.tar.bz2
gentoo-071aefbb22ddad3fbd8e905fb334408b442f7e10.zip
dev-db/pgpool2: Bump to 4.2.2
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgpool2')
-rw-r--r--dev-db/pgpool2/Manifest1
-rw-r--r--dev-db/pgpool2/pgpool2-4.2.2.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-db/pgpool2/Manifest b/dev-db/pgpool2/Manifest
index 73364f57dec4..2d63ff7e8e99 100644
--- a/dev-db/pgpool2/Manifest
+++ b/dev-db/pgpool2/Manifest
@@ -1 +1,2 @@
DIST pgpool-II-4.2.1.tar.gz 4713114 BLAKE2B 207cb3c43e47d40385d6808195561117293e5acec6bc34664ec7a1d8754bf9beb8c5350252a4274d4c50520254089f0e5a5fdfc0faf778186fa8000db6124df2 SHA512 b859a3952f69dd98a3df60b33b801d3bc96b9a11757593795a89751abe558c6baab10a37701d69d415c9da26a16abcdc72e0209e74c62204facfb25cdbc512f8
+DIST pgpool-II-4.2.2.tar.gz 4734840 BLAKE2B 2b4d26991732293e1411d1219f85a8c9ad1dca72c63069381ae1377a02ae215e813356172f3b89b42b9140549c92c76d443b125bb65cbc6abf03d2b99cf18dab SHA512 a147c810cc691fb27b823a813cbd2eaad66822c7c9f5c0f829cc70d4ac65911bbe827640f2dbd8060913276ed97340b52167e4332e9cdf013b6c9bc144c7b5d8
diff --git a/dev-db/pgpool2/pgpool2-4.2.2.ebuild b/dev-db/pgpool2/pgpool2-4.2.2.ebuild
new file mode 100644
index 000000000000..e9e995be4ddb
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-4.2.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+
+inherit autotools postgres-multi
+
+MY_P="${PN/2/-II}-${PV}"
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="https://www.pgpool.net/"
+SRC_URI="https://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc libressl memcached pam ssl static-libs"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ net-libs/libnsl:0=
+ memcached? ( dev-libs/libmemcached )
+ pam? ( sys-auth/pambase )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ postgres_new_user pgpool
+
+ postgres-multi_pkg_setup
+}
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}/pgpool-4.2.0-configure-memcached.patch" \
+ "${FILESDIR}/pgpool-configure-pam.patch" \
+ "${FILESDIR}/pgpool-4.2.0-configure-pthread.patch" \
+ "${FILESDIR}/pgpool-4.2.0-run_paths.patch"
+
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ postgres-multi_foreach econf \
+ --disable-rpath \
+ --sysconfdir="${EROOT}/etc/${PN}" \
+ --with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
+ --with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
+ $(use_enable static-libs static) \
+ $(use_with memcached) \
+ $(use_with pam) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ # Even though we're only going to do an install for the best slot
+ # available, the extension bits in src/sql need some things outside
+ # of that directory built, too.
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C src/sql
+}
+
+src_install() {
+ # We only need the best stuff installed
+ postgres-multi_forbest emake DESTDIR="${D}" install
+
+ # Except for the extension and .so files that each PostgreSQL slot needs
+ postgres-multi_foreach emake DESTDIR="${D}" -C src/sql install
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # Documentation!
+ dodoc NEWS TODO
+ doman doc/src/sgml/man{1,8}/*
+ use doc && dodoc -r doc/src/sgml/html
+
+ # mv some files that get installed to /usr/share/pgpool-II so that
+ # they all wind up in the same place
+ mv "${ED}/usr/share/${PN/2/-II}" "${ED}/usr/share/${PN}" || die
+
+ # One more thing: Evil la files!
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}