summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-09-30 19:02:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-09-30 19:02:40 +0000
commitfd8ac3f9f7aed7cc9a1241435a75bf4dd3bbb2a9 (patch)
treef2abf1dfa0fc71e5432500f1c1610116977de8ab /dev-db/pgrouting
parentdev-util/woke: stable 0.14.0 on amd64 (diff)
downloadgentoo-fd8ac3f9f7aed7cc9a1241435a75bf4dd3bbb2a9.tar.gz
gentoo-fd8ac3f9f7aed7cc9a1241435a75bf4dd3bbb2a9.tar.bz2
gentoo-fd8ac3f9f7aed7cc9a1241435a75bf4dd3bbb2a9.zip
dev-db/pgrouting: Bump to 3.2.1
Also support postgres-14 Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/pgrouting')
-rw-r--r--dev-db/pgrouting/Manifest1
-rw-r--r--dev-db/pgrouting/pgrouting-3.2.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/pgrouting/Manifest b/dev-db/pgrouting/Manifest
index ef3296245231..c87ff7d72cf0 100644
--- a/dev-db/pgrouting/Manifest
+++ b/dev-db/pgrouting/Manifest
@@ -1,3 +1,4 @@
DIST pgrouting-3.1.1.tar.gz 6133979 BLAKE2B b7657eeb88773773e6166190cda73d9e657774ff81ce7e9f005333a8dcb9d56587d4a793410356092bb1623ec287549dbc60d814b1d5156ff28301503acee776 SHA512 73285d2d47be844203df136b8a8c13d1672ad8c2dac44a1ff7ce16e4676043692a8f2a60a305542132891da83560c49c5eaeb7712e3e3dd250cd8fd550260d4a
DIST pgrouting-3.1.2.tar.gz 6063893 BLAKE2B a371fb9c744b14072c65af5ceb1ea73d2cdb69821626be3ac79e08c9dee854272ce8cb3816d1de3eade06d50a7520846dd6bccda06934b9db926f9092719f131 SHA512 3cf3e0a4a726f6f11887d15ad71b789a9067f3bc5a675288f22730215aa12d12b94d75f9bdc8ab3077de8368c45c55c0dc27128d0453c4c30965bfc0cf118dcd
DIST pgrouting-3.1.3.tar.gz 6057504 BLAKE2B 73bc5d810a2f7bb383ba4fef4ffa52ccb3f21dbc00c68f02665dc459c0e0a2810e0ed10ab73bb3099be5ea6dde86bad884d82039a50c9c4eb423b614845e94b6 SHA512 1051f0a91813ccb3c396c78a059b99839b3352e562372bcc459dfaf289e35ea08bdba8a159032a3df46913548fc717968c187b8c480187497a5b5f7327ca470e
+DIST pgrouting-3.2.1.tar.gz 5940439 BLAKE2B 01f4ec19d4cee9165a5aca946935cf4786a42f943602eca99414b536dec11ffe298f960e11aaa8b747c1b9c1839625ac9d3e7f67f1f606e941c9c738b4970479 SHA512 ead51de138950707008a7ea6b1a18cfe4d8b1885bfe92849464c2714e39f8e43ef3dbebd1c68279987a1321705fe33a598efb463078491d52cb90a8d1a0414c7
diff --git a/dev-db/pgrouting/pgrouting-3.2.1.ebuild b/dev-db/pgrouting/pgrouting-3.2.1.ebuild
new file mode 100644
index 000000000000..b7b14cb31517
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-3.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE="Release"
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+POSTGRES_USEDEP="server"
+
+inherit cmake postgres-multi
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="https://pgrouting.org/"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+
+RDEPEND="${POSTGRES_DEP}
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ sci-mathematics/cgal
+"
+
+DEPEND="${RDEPEND}"
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+src_prepare() {
+ cmake_src_prepare
+ postgres-multi_src_prepare
+}
+
+my_src_configure() {
+ local mycmakeargs=( -DPOSTGRESQL_BIN="$($PG_CONFIG --bindir)" )
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach my_src_configure
+}
+
+src_compile() {
+ postgres-multi_foreach cmake_build
+}
+
+src_install() {
+ postgres-multi_foreach cmake_src_install
+}