summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-11-28 06:25:18 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-11-28 06:25:55 -0500
commit7b1bad3a6068b974161b6404cb21a85227637e6e (patch)
tree463c5e7bf1f6a4436ea5a3d7b1a182a311771958 /dev-db/pgtap/pgtap-0.99.0.ebuild
parentdev-db/pgpool2: Bump to 3.7.7, 4.0.2 (diff)
downloadgentoo-7b1bad3a6068b974161b6404cb21a85227637e6e.tar.gz
gentoo-7b1bad3a6068b974161b6404cb21a85227637e6e.tar.bz2
gentoo-7b1bad3a6068b974161b6404cb21a85227637e6e.zip
dev-db/pgtap: Bump to 0.99.0
Ebuild now restricts tests. Bug: https://bugs.gentoo.org/663792 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db/pgtap/pgtap-0.99.0.ebuild')
-rw-r--r--dev-db/pgtap/pgtap-0.99.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-db/pgtap/pgtap-0.99.0.ebuild b/dev-db/pgtap/pgtap-0.99.0.ebuild
new file mode 100644
index 000000000000..2be40ea3ba4a
--- /dev/null
+++ b/dev-db/pgtap/pgtap-0.99.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+POSTGRES_COMPAT=( 9.{3..6} {10..11} )
+
+inherit postgres-multi
+
+DESCRIPTION="Unit testing for PostgreSQL"
+HOMEPAGE="https://pgtap.org/"
+SRC_URI="https://api.pgxn.org/dist/${PN}/${PV}/${P}.zip"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="${POSTGRES_DEP}
+ app-arch/unzip
+ dev-perl/TAP-Parser-SourceHandler-pgTAP
+"
+RDEPEND="${DEPEND}"
+
+# Tests requires a running database that match up with the current testing slot.
+RESTRICT="test"
+
+src_configure() {
+ :
+}