summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-08 05:13:09 +0000
committerSam James <sam@gentoo.org>2021-12-08 05:13:18 +0000
commit910b07df93db62c0a48ee5cbaa865e7ded05a976 (patch)
treecd426cd7a6b8832b3b452193a54669a6fdbf6bd4 /dev-db/postgis
parentdev-db/postgis: depend on <PROJ 8 for some versions (diff)
downloadgentoo-910b07df93db62c0a48ee5cbaa865e7ded05a976.tar.gz
gentoo-910b07df93db62c0a48ee5cbaa865e7ded05a976.tar.bz2
gentoo-910b07df93db62c0a48ee5cbaa865e7ded05a976.zip
dev-db/postgis: update EAPI 6 -> 7 (sync live ebuild)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/postgis-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-db/postgis/postgis-9999.ebuild b/dev-db/postgis/postgis-9999.ebuild
index 8325204434e1..298c281eae44 100644
--- a/dev-db/postgis/postgis-9999.ebuild
+++ b/dev-db/postgis/postgis-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-POSTGRES_COMPAT=( 9.6 {10..12} )
+POSTGRES_COMPAT=( 9.6 {10..14} )
POSTGRES_USEDEP="server"
-inherit autotools eapi7-ver postgres-multi
+inherit autotools postgres-multi toolchain-funcs
MY_P="${PN}-$(ver_rs 3 '')"
@@ -25,9 +25,9 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="address-standardizer doc gtk static-libs test topology"
+IUSE="address-standardizer doc gtk static-libs topology"
-REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
+REQUIRED_USE="${POSTGRES_REQ_USE}"
# Needs a running psql instance, doesn't work out of the box
RESTRICT="test"
@@ -36,7 +36,7 @@ RDEPEND="${POSTGRES_DEP}
dev-libs/json-c:=
dev-libs/libxml2:2
dev-libs/protobuf-c:=
- >=sci-libs/geos-3.6.0
+ >=sci-libs/geos-3.9.0
>=sci-libs/proj-4.9.0:=
>=sci-libs/gdal-1.10.0:=
address-standardizer? ( dev-libs/libpcre )
@@ -50,10 +50,13 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
virtual/imagemagick-tools[png]
)
- test? ( dev-util/cunit )
"
-PATCHES=( "${FILESDIR}/${PN}-2.2.0-arflags.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-arflags.patch"
+ "${FILESDIR}/${PN}-3.0.3-avoid-calling-ar-directly.patch"
+ "${FILESDIR}/${PN}-3.0.3-try-other-cpp-names.patch"
+)
src_prepare() {
default
@@ -78,8 +81,9 @@ src_prepare() {
}
src_configure() {
+ export CPP=$(tc-getCPP)
+
local myeconfargs=(
- --with-protobuf # funky misdetection if enabled but --without-protobuf
$(use_with address-standardizer)
$(use_with gtk gui)
$(use_with topology)