summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2015-09-06 08:12:54 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2015-09-06 08:12:54 -0400
commitc806983cde723cef328e6d7997e04b29a95e24c1 (patch)
tree7776597862b04f54ad8e77eb3bd819f1544abc42 /dev-db/postgresql
parentdev-libs/libgpg-error: sparc stable, bug #552938 (diff)
downloadgentoo-c806983cde723cef328e6d7997e04b29a95e24c1.tar.gz
gentoo-c806983cde723cef328e6d7997e04b29a95e24c1.tar.bz2
gentoo-c806983cde723cef328e6d7997e04b29a95e24c1.zip
dev-db/postgresql: Fix No Server Patch
Makefiles were changed slightly for 9.5. Patch updated so that it can be applied.
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/files/postgresql-9.5-no-server.patch78
1 files changed, 39 insertions, 39 deletions
diff --git a/dev-db/postgresql/files/postgresql-9.5-no-server.patch b/dev-db/postgresql/files/postgresql-9.5-no-server.patch
index 1a12d5b820b2..c5e2c7ddd3b8 100644
--- a/dev-db/postgresql/files/postgresql-9.5-no-server.patch
+++ b/dev-db/postgresql/files/postgresql-9.5-no-server.patch
@@ -1,8 +1,7 @@
-diff --git a/contrib/Makefile b/contrib/Makefile
-index b37d0dd..b56fbf6 100644
---- a/contrib/Makefile
-+++ b/contrib/Makefile
-@@ -5,64 +5,9 @@ top_builddir = ..
+diff -ru a/contrib/Makefile b/contrib/Makefile
+--- a/contrib/Makefile 2015-06-29 15:42:18.000000000 -0400
++++ b/contrib/Makefile 2015-09-06 07:50:51.258463861 -0400
+@@ -5,56 +5,9 @@
include $(top_builddir)/src/Makefile.global
SUBDIRS = \
@@ -17,7 +16,6 @@ index b37d0dd..b56fbf6 100644
- dblink \
- dict_int \
- dict_xsyn \
-- dummy_seclabel \
- earthdistance \
- file_fdw \
- fuzzystrmatch \
@@ -30,47 +28,39 @@ index b37d0dd..b56fbf6 100644
oid2name \
- pageinspect \
- passwordcheck \
-- pg_archivecleanup \
- pg_buffercache \
- pg_freespacemap \
- pg_prewarm \
- pg_standby \
- pg_stat_statements \
-- pg_test_fsync \
-- pg_test_timing \
- pg_trgm \
-- pg_upgrade \
-- pg_upgrade_support \
- pgbench \
- pgcrypto \
- pgrowlocks \
- pgstattuple \
-- pg_xlogdump \
- postgres_fdw \
- seg \
- spi \
- tablefunc \
- tcn \
- test_decoding \
-- test_parser \
-- test_shm_mq \
+- tsm_system_rows \
+- tsm_system_time \
- tsearch2 \
- unaccent \
-- vacuumlo \
-- worker_spi
--
+ vacuumlo
+
-ifeq ($(with_openssl),yes)
-SUBDIRS += sslinfo
-else
-ALWAYS_SUBDIRS += sslinfo
-endif
-+ vacuumlo
-
+-
ifneq ($(with_uuid),no)
SUBDIRS += uuid-ossp
-diff -Naur a/src/backend/Makefile b/src/backend/Makefile
---- a/src/backend/Makefile 2013-05-06 20:57:06.000000000 +0000
-+++ b/src/backend/Makefile 2013-06-09 01:50:19.655864258 +0000
+ else
+diff -ru a/src/backend/Makefile b/src/backend/Makefile
+--- a/src/backend/Makefile 2015-06-29 15:42:18.000000000 -0400
++++ b/src/backend/Makefile 2015-09-06 08:01:36.775374842 -0400
@@ -47,7 +47,7 @@
##########################################################################
@@ -80,7 +70,7 @@ diff -Naur a/src/backend/Makefile b/src/backend/Makefile
ifneq ($(PORTNAME), cygwin)
ifneq ($(PORTNAME), win32)
-@@ -116,7 +116,7 @@
+@@ -106,7 +106,7 @@
endif # aix
# Update the commonly used headers before building the subdirectories
@@ -89,7 +79,7 @@ diff -Naur a/src/backend/Makefile b/src/backend/Makefile
# run this unconditionally to avoid needing to know its dependencies here:
submake-schemapg:
-@@ -209,23 +209,8 @@
+@@ -199,23 +199,7 @@
##########################################################################
@@ -111,26 +101,36 @@ diff -Naur a/src/backend/Makefile b/src/backend/Makefile
- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample '$(DESTDIR)$(datadir)/recovery.conf.sample'
+install:
-+
install-bin: postgres $(POSTGRES_IMP) installdirs
$(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
-diff -Naur a/src/bin/Makefile b/src/bin/Makefile
---- a/src/bin/Makefile 2013-05-06 20:57:06.000000000 +0000
-+++ b/src/bin/Makefile 2013-06-09 01:51:56.143824442 +0000
-@@ -13,8 +13,7 @@
- top_builddir = ../..
+diff -ru a/src/bin/Makefile b/src/bin/Makefile
+--- a/src/bin/Makefile 2015-06-29 15:42:18.000000000 -0400
++++ b/src/bin/Makefile 2015-09-06 08:03:27.014847309 -0400
+@@ -14,20 +14,8 @@
include $(top_builddir)/src/Makefile.global
--SUBDIRS = initdb pg_ctl pg_dump \
-- psql scripts pg_config pg_controldata pg_resetxlog pg_basebackup
-+SUBDIRS = pg_dump psql scripts pg_config
+ SUBDIRS = \
+- initdb \
+- pg_archivecleanup \
+- pg_basebackup \
+ pg_config \
+- pg_controldata \
+- pg_ctl \
+ pg_dump \
+- pg_resetxlog \
+- pg_rewind \
+- pg_test_fsync \
+- pg_test_timing \
+- pg_upgrade \
+- pg_xlogdump \
+- pgbench \
+ psql \
+ scripts
- ifeq ($(PORTNAME), win32)
- SUBDIRS += pgevent
-diff -Naur a/src/Makefile b/src/Makefile
---- a/src/Makefile 2013-05-06 20:57:06.000000000 +0000
-+++ b/src/Makefile 2013-06-09 01:54:30.479704228 +0000
+diff -ru a/src/Makefile b/src/Makefile
+--- a/src/Makefile 2015-06-29 15:42:18.000000000 -0400
++++ b/src/Makefile 2015-09-06 08:04:25.274568519 -0400
@@ -15,17 +15,11 @@
SUBDIRS = \
common \