summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-11 21:09:25 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-11 23:02:10 +0100
commitcbc076540f6fc01308819a1cb21cd10df53c484b (patch)
treef23187717567b65bb7d99931acc328d389984201 /dev-db/postgresql
parentapp-eselect/eselect-postgresql: keyword 2.4 for ~riscv (diff)
downloadgentoo-cbc076540f6fc01308819a1cb21cd10df53c484b.tar.gz
gentoo-cbc076540f6fc01308819a1cb21cd10df53c484b.tar.bz2
gentoo-cbc076540f6fc01308819a1cb21cd10df53c484b.zip
dev-db/postgresql: disable spinlocks on riscv
No native spinlock support for this arch yet, not even in Git head. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/postgresql-13.3.ebuild12
-rw-r--r--dev-db/postgresql/postgresql-14_beta2.ebuild12
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild12
3 files changed, 27 insertions, 9 deletions
diff --git a/dev-db/postgresql/postgresql-13.3.ebuild b/dev-db/postgresql/postgresql-13.3.ebuild
index d71750a1cb74..2e2bf1e36a3c 100644
--- a/dev-db/postgresql/postgresql-13.3.ebuild
+++ b/dev-db/postgresql/postgresql-13.3.ebuild
@@ -134,14 +134,13 @@ src_configure() {
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
- econf \
+ local myconf="\
--prefix="${PO}/usr/$(get_libdir)/postgresql-${SLOT}" \
--datadir="${PO}/usr/share/postgresql-${SLOT}" \
--includedir="${PO}/usr/include/postgresql-${SLOT}" \
--mandir="${PO}/usr/share/postgresql-${SLOT}/man" \
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
- $(use_enable !alpha spinlocks) \
$(use_enable debug) \
$(use_enable threads thread-safety) \
$(use_with icu) \
@@ -159,7 +158,14 @@ src_configure() {
$(use_with xml libxml) \
$(use_with xml libxslt) \
$(use_with zlib) \
- $(use_enable nls)
+ $(use_enable nls)"
+ if use alpha || use riscv; then
+ myconf+=" --disable-spinlocks"
+ else
+ # Should be the default but just in case
+ myconf+=" --enable-spinlocks"
+ fi
+ econf ${myconf}
}
src_compile() {
diff --git a/dev-db/postgresql/postgresql-14_beta2.ebuild b/dev-db/postgresql/postgresql-14_beta2.ebuild
index a9630c760e88..e6463312ebcb 100644
--- a/dev-db/postgresql/postgresql-14_beta2.ebuild
+++ b/dev-db/postgresql/postgresql-14_beta2.ebuild
@@ -135,14 +135,13 @@ src_configure() {
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
- econf \
+ local myconf="\
--prefix="${PO}/usr/$(get_libdir)/postgresql-${SLOT}" \
--datadir="${PO}/usr/share/postgresql-${SLOT}" \
--includedir="${PO}/usr/include/postgresql-${SLOT}" \
--mandir="${PO}/usr/share/postgresql-${SLOT}/man" \
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
- $(use_enable !alpha spinlocks) \
$(use_enable debug) \
$(use_enable threads thread-safety) \
$(use_with icu) \
@@ -161,7 +160,14 @@ src_configure() {
$(use_with xml libxml) \
$(use_with xml libxslt) \
$(use_with zlib) \
- $(use_enable nls)
+ $(use_enable nls)"
+ if use alpha || use riscv; then
+ myconf+=" --disable-spinlocks"
+ else
+ # Should be the default but just in case
+ myconf+=" --enable-spinlocks"
+ fi
+ econf ${myconf}
}
src_compile() {
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 106cb9fb88fe..8bdc4467a149 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -151,14 +151,13 @@ src_configure() {
[[ -z $uuid_config ]] && uuid_config="--with-uuid=ossp"
fi
- econf \
+ local myconf="\
--prefix="${PO}/usr/$(get_libdir)/postgresql-${SLOT}" \
--datadir="${PO}/usr/share/postgresql-${SLOT}" \
--includedir="${PO}/usr/include/postgresql-${SLOT}" \
--mandir="${PO}/usr/share/postgresql-${SLOT}/man" \
--sysconfdir="${PO}/etc/postgresql-${SLOT}" \
--with-system-tzdata="${PO}/usr/share/zoneinfo" \
- $(use_enable !alpha spinlocks) \
$(use_enable debug) \
$(use_enable nls) \
$(use_enable threads thread-safety) \
@@ -177,7 +176,14 @@ src_configure() {
$(use_with xml libxslt) \
$(use_with zlib) \
$(use_with systemd) \
- ${uuid_config}
+ ${uuid_config}"
+ if use alpha || use riscv; then
+ myconf+=" --disable-spinlocks"
+ else
+ # Should be the default but just in case
+ myconf+=" --enable-spinlocks"
+ fi
+ econf ${myconf}
}
src_compile() {