summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/qdbm/qdbm-1.8.78-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/qdbm/qdbm-1.8.78-r1.ebuild')
-rw-r--r--dev-db/qdbm/qdbm-1.8.78-r1.ebuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/dev-db/qdbm/qdbm-1.8.78-r1.ebuild b/dev-db/qdbm/qdbm-1.8.78-r1.ebuild
new file mode 100644
index 000000000000..6baac1adb4f0
--- /dev/null
+++ b/dev-db/qdbm/qdbm-1.8.78-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils java-pkg-opt-2 multilib
+
+DESCRIPTION="Quick Database Manager"
+HOMEPAGE="http://fallabs.com/qdbm/"
+SRC_URI="http://fallabs.com/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="cxx debug java perl ruby zlib"
+
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ perl? ( dev-lang/perl )
+ ruby? ( dev-lang/ruby )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.4 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-runpath.diff
+ epatch "${FILESDIR}"/${PN}-perl-runpath-vendor.diff
+ epatch "${FILESDIR}"/${PN}-ruby19.diff
+ # apply flags
+ sed -i "/^CFLAGS/s|$| ${CFLAGS}|" Makefile.in
+ sed -i "/^OPTIMIZE/s|$| ${CFLAGS}|" perl/Makefile.in
+ sed -i "/^CXXFLAGS/s|$| ${CXXFLAGS}|" plus/Makefile.in
+ sed -i "/^JAVACFLAGS/s|$| ${JAVACFLAGS}|" java/Makefile.in
+ # replace make -> $(MAKE)
+ sed -i "s/make\( \|$\)/\$(MAKE)\1/g" \
+ Makefile.in \
+ {cgi,java,perl,plus,ruby}/Makefile.in
+}
+
+qdbm_api_for() {
+ local u
+ for u in cxx java perl ruby; do
+ if ! use "${u}"; then
+ continue
+ fi
+ if [ "${u}" = "cxx" ]; then
+ u="plus"
+ fi
+ cd "${u}"
+ case "${EBUILD_PHASE}" in
+ configure)
+ econf
+ ;;
+ compile)
+ emake
+ ;;
+ test)
+ emake -j1 check
+ ;;
+ install)
+ emake DESTDIR="${D}" MYDATADIR=/usr/share/doc/${P}/html install
+ esac
+ cd -
+ done
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable zlib) \
+ --enable-pthread \
+ --enable-iconv
+ qdbm_api_for # configure
+}
+
+src_compile() {
+ emake
+ qdbm_api_for # compile
+}
+
+src_test() {
+ emake -j1 check
+ qdbm_api_for # test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README THANKS
+ dohtml -r doc/
+ rm -rf "${ED}"/usr/share/${PN}
+
+ qdbm_api_for # install
+
+ if use java; then
+ java-pkg_dojar "${ED}"/usr/$(get_libdir)/*.jar
+ rm -f "${ED}"/usr/$(get_libdir)/*.jar
+ fi
+ if use perl; then
+ rm -f "${ED}"/$(perl -V:installarchlib | cut -d\' -f2)/*.pod
+ find "${ED}" -name .packlist -print0 | xargs -0 rm -f
+ fi
+
+ rm -f "${ED}"/usr/bin/*test
+ rm -f "${ED}"/usr/share/man/man1/*test.1*
+}