summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-04-17 22:08:23 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-04-17 22:10:34 -0700
commit2b5acf19be8645e316cdd35f336a9b641a49e684 (patch)
tree1ed5c513f5080ea6358a065ebc6bbc546a5d62bd /dev-db/redis
parentdev-db/redis: fix Tcl BDEPEND req (diff)
downloadgentoo-2b5acf19be8645e316cdd35f336a9b641a49e684.tar.gz
gentoo-2b5acf19be8645e316cdd35f336a9b641a49e684.tar.bz2
gentoo-2b5acf19be8645e316cdd35f336a9b641a49e684.zip
dev-db/redis: GitHub PR dropped slotted-Lua improvements
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/redis-4.0.14.ebuild21
-rw-r--r--dev-db/redis/redis-5.0.4.ebuild20
2 files changed, 34 insertions, 7 deletions
diff --git a/dev-db/redis/redis-4.0.14.ebuild b/dev-db/redis/redis-4.0.14.ebuild
index 5f2c18f61cbc..08d29146a9bc 100644
--- a/dev-db/redis/redis-4.0.14.ebuild
+++ b/dev-db/redis/redis-4.0.14.ebuild
@@ -71,15 +71,28 @@ src_prepare() {
cp "${FILESDIR}"/configure.ac-3.2 configure.ac || die
# Use the correct pkgconfig name for Lua
- has_version 'dev-lang/lua:5.1' \
- && LUAPKGCONFIG=lua5.1 \
- || LUAPKGCONFIG=lua
+ if false && has_version 'dev-lang/lua:5.3'; then
+ # Lua5.3 gives:
+ #lua_bit.c:83:2: error: #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
+ LUAPKGCONFIG=lua5.3
+ elif false && has_version 'dev-lang/lua:5.2'; then
+ # Lua5.2 fails with:
+ # scripting.c:(.text+0x1f9b): undefined reference to `lua_open'
+ # Because lua_open because lua_newstate in 5.2
+ LUAPKGCONFIG=lua5.2
+ elif has_version 'dev-lang/lua:5.1'; then
+ LUAPKGCONFIG=lua5.1
+ else
+ LUAPKGCONFIG=lua
+ fi
+ # The upstream configure script handles luajit specially, and is not
+ # effected by these changes.
+ einfo "Selected LUAPKGCONFIG=${LUAPKGCONFIG}"
sed -i \
-e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \
-e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
-e "/PKG_CHECK_MODULES.*\<LUA\>/s,lua5.1,${LUAPKGCONFIG},g" \
configure.ac || die "Sed failed for configure.ac"
-
eautoreconf
}
diff --git a/dev-db/redis/redis-5.0.4.ebuild b/dev-db/redis/redis-5.0.4.ebuild
index 519fc3837ca9..07c6466e9a12 100644
--- a/dev-db/redis/redis-5.0.4.ebuild
+++ b/dev-db/redis/redis-5.0.4.ebuild
@@ -71,9 +71,23 @@ src_prepare() {
cp "${FILESDIR}"/configure.ac-3.2 configure.ac || die
# Use the correct pkgconfig name for Lua
- has_version 'dev-lang/lua:5.1' \
- && LUAPKGCONFIG=lua5.1 \
- || LUAPKGCONFIG=lua
+ if false && has_version 'dev-lang/lua:5.3'; then
+ # Lua5.3 gives:
+ #lua_bit.c:83:2: error: #error "Unknown number type, check LUA_NUMBER_* in luaconf.h"
+ LUAPKGCONFIG=lua5.3
+ elif false && has_version 'dev-lang/lua:5.2'; then
+ # Lua5.2 fails with:
+ # scripting.c:(.text+0x1f9b): undefined reference to `lua_open'
+ # Because lua_open because lua_newstate in 5.2
+ LUAPKGCONFIG=lua5.2
+ elif has_version 'dev-lang/lua:5.1'; then
+ LUAPKGCONFIG=lua5.1
+ else
+ LUAPKGCONFIG=lua
+ fi
+ # The upstream configure script handles luajit specially, and is not
+ # effected by these changes.
+ einfo "Selected LUAPKGCONFIG=${LUAPKGCONFIG}"
sed -i \
-e "/^AC_INIT/s|, [0-9].+, |, $PV, |" \
-e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \