summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/slony1/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/slony1/files')
-rw-r--r--dev-db/slony1/files/slony1-2.1.1-ldflags.patch29
-rw-r--r--dev-db/slony1/files/slony1-2.1.2-ldflags.patch17
-rw-r--r--dev-db/slony1/files/slony1.conf12
-rwxr-xr-xdev-db/slony1/files/slony1.init37
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-db/slony1/files/slony1-2.1.1-ldflags.patch b/dev-db/slony1/files/slony1-2.1.1-ldflags.patch
new file mode 100644
index 000000000000..35452ad3b852
--- /dev/null
+++ b/dev-db/slony1/files/slony1-2.1.1-ldflags.patch
@@ -0,0 +1,29 @@
+diff -Naur a/Makefile.global.in b/Makefile.global.in
+--- a/Makefile.global.in 2012-01-25 14:13:40.000000000 -0500
++++ b/Makefile.global.in 2012-02-22 06:14:05.240047000 -0500
+@@ -80,7 +80,7 @@
+ subdir=$(slony_subdir)
+
+ override CPPFLAGS := -I${pgincludeserverdir} -I${pgincludedir} $(CPPFLAGS)
+-LDFLAGS = -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
++override LDFLAGS += -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
+
+ ifeq ($(GCC), yes)
+ CFLAGS += -Wall -Wmissing-prototypes -Wmissing-declarations
+diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+--- a/makefiles/Makefile.linux 2012-01-25 14:13:40.000000000 -0500
++++ b/makefiles/Makefile.linux 2012-02-22 06:15:45.652523000 -0500
+@@ -12,9 +12,9 @@
+ endif
+
+ %.so: %.o
+- $(CC) -shared -o $@ $<
++ $(CC) $(LDFLAGS) -shared -o $@ $<
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
+
+-sqlmansect = 7
+\ No newline at end of file
++sqlmansect = 7
diff --git a/dev-db/slony1/files/slony1-2.1.2-ldflags.patch b/dev-db/slony1/files/slony1-2.1.2-ldflags.patch
new file mode 100644
index 000000000000..038b2ee20fb5
--- /dev/null
+++ b/dev-db/slony1/files/slony1-2.1.2-ldflags.patch
@@ -0,0 +1,17 @@
+diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+--- a/makefiles/Makefile.linux 2012-01-25 14:13:40.000000000 -0500
++++ b/makefiles/Makefile.linux 2012-02-22 06:15:45.652523000 -0500
+@@ -12,9 +12,9 @@
+ endif
+
+ %.so: %.o
+- $(CC) -shared -o $@ $<
++ $(CC) $(LDFLAGS) -shared -o $@ $<
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
+
+-sqlmansect = 7
+\ No newline at end of file
++sqlmansect = 7
diff --git a/dev-db/slony1/files/slony1.conf b/dev-db/slony1/files/slony1.conf
new file mode 100644
index 000000000000..219092bd1294
--- /dev/null
+++ b/dev-db/slony1/files/slony1.conf
@@ -0,0 +1,12 @@
+# /etc/conf.d/slony1:
+# $Id$
+
+# Configuration file for /etc/init.d/slony1
+
+USER=postgres
+CLUSTER=your_cluster_name
+DBUSER=postgres
+DBNAME=your_database_name
+DBHOST=localhost
+LOGFILE=/var/lib/postgresql/data/slony1.log
+LOGLEVEL=1 # 1(minimum)..4(maximum)
diff --git a/dev-db/slony1/files/slony1.init b/dev-db/slony1/files/slony1.init
new file mode 100755
index 000000000000..1e1443b0ac2f
--- /dev/null
+++ b/dev-db/slony1/files/slony1.init
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need postgresql
+}
+
+start() {
+ ebegin "Starting slony1"
+ /usr/bin/slon -p /var/run/slony1.pid -d $LOGLEVEL $CLUSTER "dbname=$DBNAME user=$DBUSER host=$DBHOST" >> $LOGFILE 2>&1 &
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "/var/run/slony1.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $LOGFILE"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping slony1"
+ kill `cat /var/run/slony1.pid`
+ eend $?
+}
+