summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-11-30 16:55:09 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-11-30 16:55:28 +0300
commitbd74920e03ccbd498fd8bf228fb198aedfda094f (patch)
treef8b0eb728379e3515c47401c3c5524a079eccdb9 /dev-db/sqlcipher
parentdev-python/backports-abc: Bump to version 0.5 (diff)
downloadgentoo-bd74920e03ccbd498fd8bf228fb198aedfda094f.tar.gz
gentoo-bd74920e03ccbd498fd8bf228fb198aedfda094f.tar.bz2
gentoo-bd74920e03ccbd498fd8bf228fb198aedfda094f.zip
dev-db/sqlcipher: version bump
EAPI 6, switch from autotools-multilib to multilib-minimal eclass. Add support for libressl. Reported-by: Ian <csmk@chaoslab.org> Gentoo-Bug: 598402 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-db/sqlcipher')
-rw-r--r--dev-db/sqlcipher/Manifest1
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.4.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/Manifest b/dev-db/sqlcipher/Manifest
index 0e21d044dc5b..f4443ba80d76 100644
--- a/dev-db/sqlcipher/Manifest
+++ b/dev-db/sqlcipher/Manifest
@@ -1 +1,2 @@
DIST sqlcipher-3.3.0.tar.gz 10235736 SHA256 18f5df41a9806bc8eece00fde24c85107bd4807a5ae7057f9a6188de5d8fd82a SHA512 9f24fcd25811aabe36f5e27cdfc117a02ad3578a95691e9b3b7f41ee47ee0c176243c4f35a8415a17a3828d4534aae58a1097b75a950937706b10a79f2c92c81 WHIRLPOOL 1f4bdaf9ead7e2834d1efd2612c74eb91df2bbc17dfa4d404a72db4ef837b6b7a8430da522b6ec708f8873482c2de318a3cf65aebfdc53c200cad53a4ded9e6b
+DIST sqlcipher-3.4.0.tar.gz 13600901 SHA256 99b702ecf796de02bf7b7b35de4ceef145f0d62b4467a86707c2d59beea243d0 SHA512 c9b7db77b742a61b5befc33f63070a2970137e0c57892ba554a37e3ca51e42dd1164a6789d21958375ed7f38ee919bfc1332eb9da8307e6fa3805d9f9c409d9c WHIRLPOOL 644b4193dc128a2bbb5ba71867d6e919ae22894143ffc3c8d6a8d103aa8ed22795cfa2b7e1e04e54f38df00c86e0534bf04be1bc9df92be32c56da6b834376d7
diff --git a/dev-db/sqlcipher/sqlcipher-3.4.0.ebuild b/dev-db/sqlcipher/sqlcipher-3.4.0.ebuild
new file mode 100644
index 000000000000..ebc5d00bb413
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-3.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="https://www.zetetic.net/sqlcipher/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="readline libressl static-libs tcl test"
+
+# Tcl is always needed by buildsystem
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-lang/tcl:*"
+
+# Testsuite requires compilation with TCL, bug #582584
+REQUIRED_USE="test? ( tcl )"
+
+DOCS=( README.md )
+
+src_prepare() {
+ append-cflags -DSQLITE_HAS_CODEC
+
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-fts3 \
+ --enable-fts4 \
+ --enable-fts5 \
+ --enable-json1 \
+ --enable-tempstore \
+ $(use_enable readline) \
+ $(use_enable static-libs static) \
+ $(use_enable tcl)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}