summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2019-10-08 07:46:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-10-10 16:56:56 +0300
commitaf6fa83420dae507bff24ecd14d0323438b247a8 (patch)
treea99450c5d93b3d8c15b3e575c100b0c6a8e05657 /dev-db/sqlcl-bin
parentapp-admin/cdist: cleanup old versions (diff)
downloadgentoo-af6fa83420dae507bff24ecd14d0323438b247a8.tar.gz
gentoo-af6fa83420dae507bff24ecd14d0323438b247a8.tar.bz2
gentoo-af6fa83420dae507bff24ecd14d0323438b247a8.zip
dev-db/sqlcl-bin: bump to version 19.2.1.206.1649
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Bug: https://bugs.gentoo.org/696716 Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db/sqlcl-bin')
-rw-r--r--dev-db/sqlcl-bin/Manifest1
-rw-r--r--dev-db/sqlcl-bin/sqlcl-bin-19.2.1.206.1649.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-db/sqlcl-bin/Manifest b/dev-db/sqlcl-bin/Manifest
index ff4d614d9e4d..a82d6c2c6ce5 100644
--- a/dev-db/sqlcl-bin/Manifest
+++ b/dev-db/sqlcl-bin/Manifest
@@ -1 +1,2 @@
DIST sqlcl-19.1.0.094.1619.zip 21886970 BLAKE2B adf3e70521eb38b1504a384512b2c92222121084e27e98952d0f493d74fff63d6f24c00e9f1ed025cccef3305cdc47acecde604575a63221b4fedf38fa6e1885 SHA512 1d04fc7e1a9229badafeea54489db5c6ee8b3d720d84687cbdf761232388e624ac66d0ae59de99e833ae36eb3d5287d1ea556d09aad855d75b674186c55ed9a8
+DIST sqlcl-19.2.1.206.1649.zip 24998252 BLAKE2B bb6148235477133439c3b549cfaefd96249ce661a766e69defb77fc32921db4158114386620b4227626446a560c80447f17ba7fcdbcc1eb834df7a71f61e6dcf SHA512 9d43278f7a296e1a5d57d1418007e3aa7b20723e7452543779e5f2c4ad962bea2b2599db32172406bb01278548edb11b24e34c85e4975664883f469f285150a4
diff --git a/dev-db/sqlcl-bin/sqlcl-bin-19.2.1.206.1649.ebuild b/dev-db/sqlcl-bin/sqlcl-bin-19.2.1.206.1649.ebuild
new file mode 100644
index 000000000000..140d82c85266
--- /dev/null
+++ b/dev-db/sqlcl-bin/sqlcl-bin-19.2.1.206.1649.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Oracle SQLcl is the new SQL*Plus"
+HOMEPAGE="https://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html"
+SRC_URI="${MY_P}.zip"
+RESTRICT="bindist fetch mirror"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="virtual/jre:1.8
+ dev-java/java-config:2
+ dev-db/oracle-instantclient"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please go to"
+ einfo
+ einfo " ${HOMEPAGE}"
+ einfo
+ einfo "and download"
+ einfo
+ einfo " Command Line - SQLcl"
+ einfo " ${SRC_URI}"
+ einfo
+ einfo "which must be placed in DISTDIR directory."
+}
+
+src_prepare() {
+ default
+ find ./ \( -iname "*.bat" -or -iname "*.exe" \) -delete || die "remove files failed"
+}
+
+src_install() {
+ exeinto "/opt/${MY_PN}/bin/"
+ newexe "${MY_PN}"/bin/sql sqlcl
+
+ insinto "/opt/${MY_PN}/lib/"
+ doins -r "${MY_PN}"/lib/.
+
+ dosym "../${MY_PN}/bin/sqlcl" /opt/bin/sqlcl
+}