summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 08:08:18 +0000
committerSam James <sam@gentoo.org>2021-03-05 18:00:44 +0000
commitc60adf0403436f27b02f4d6df8551efc5a5f41ea (patch)
treea263d5ab7ddf577fe833caa9eca603363649cc2f /dev-db/tokyocabinet
parentdev-db/sqlcipher: minor changes to align with 3.4.2 (diff)
downloadgentoo-c60adf0403436f27b02f4d6df8551efc5a5f41ea.tar.gz
gentoo-c60adf0403436f27b02f4d6df8551efc5a5f41ea.tar.bz2
gentoo-c60adf0403436f27b02f4d6df8551efc5a5f41ea.zip
dev-db/tokyocabinet: port to EAPI 7
* EAPI 7 * fix DeprecatedInsinto * fix econf indentation * mv deprecated configure.in * tidy patch formatting Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/files/fix_rpath.patch15
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild50
2 files changed, 37 insertions, 28 deletions
diff --git a/dev-db/tokyocabinet/files/fix_rpath.patch b/dev-db/tokyocabinet/files/fix_rpath.patch
index e1cba0a0370f..052e22f0c10f 100644
--- a/dev-db/tokyocabinet/files/fix_rpath.patch
+++ b/dev-db/tokyocabinet/files/fix_rpath.patch
@@ -1,6 +1,5 @@
-diff -ur Makefile.in Makefile.in
---- Makefile.in 2009-08-04 09:37:52.000000000 +0200
-+++ Makefile.in 2009-09-30 23:45:28.000000000 +0200
+--- a/Makefile.in
++++ b/Makefile.in
@@ -54,8 +54,8 @@
LDFLAGS = @MYLDFLAGS@
CMDLDFLAGS = @MYCMDLDFLAGS@
@@ -12,9 +11,8 @@ diff -ur Makefile.in Makefile.in
POSTCMD = @MYPOSTCMD@
-diff -ur configure.in configure.in
---- configure.in 2009-08-31 11:36:58.000000000 +0200
-+++ configure.in 2009-09-30 23:45:28.000000000 +0200
+--- a/configure.in
++++ b/configure.in
@@ -31,25 +31,15 @@
MYPCFILES="tokyocabinet.pc"
@@ -44,9 +42,8 @@ diff -ur configure.in configure.in
#================================================================
# Options
-diff -ur tokyocabinet.pc.in tokyocabinet.pc.in
---- tokyocabinet.pc.in 2008-02-18 08:25:18.000000000 +0100
-+++ tokyocabinet.pc.in 2009-09-30 23:45:28.000000000 +0200
+--- a/tokyocabinet.pc.in
++++ b/tokyocabinet.pc.in
@@ -10,5 +10,5 @@
Name: Tokyo Cabinet
Description: a modern implementation of DBM
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
index 52ddccc5c6ad..0fe6fc6285d1 100644
--- a/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.48-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="A library of routines for managing a database"
HOMEPAGE="https://fallabs.com/tokyocabinet/"
@@ -18,43 +18,55 @@ DEPEND="bzip2? ( app-arch/bzip2 )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/fix_rpath.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/fix_rpath.patch"
+ default
+
sed -i \
-e "/ldconfig/d" \
-e "/DATADIR/d" Makefile.in || die
+
# cflags fix - remove -O2 at end of line and -fomit-frame-pointer
sed -i -e 's/-O3"$/"/' configure.in || die
sed -i -e 's/-fomit-frame-pointer//' configure.in || die
+
# flag only works on x86 derivatives, remove everywhere else
- if ! use x86 && ! use amd64; then sed -i -e 's/ -minline-all-stringops//' configure.in; fi
+ if ! use x86 && ! use amd64; then
+ sed -i -e 's/ -minline-all-stringops//' configure.in || die
+ fi
+
+ mv configure.{in,ac} || die
+
eautoreconf
}
src_configure() {
# we use the "fastest" target without the -O3
econf \
- $(use_enable debug) \
- $(use_enable bzip2 bzip) \
- $(use_enable zlib) \
- $(use_enable threads pthread) \
- --enable-off64 --enable-fastest
+ $(use_enable debug) \
+ $(use_enable bzip2 bzip) \
+ $(use_enable zlib) \
+ $(use_enable threads pthread) \
+ --enable-off64 \
+ --enable-fastest
+}
+
+src_test() {
+ emake -j1 check
}
src_install() {
emake DESTDIR="${D}" install
- if use examples; then
- insinto /usr/share/${PF}/example
- doins example/*
- fi
-
if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/*
+ dodoc -r doc/*
fi
-}
-src_test() {
- emake -j1 check
+ if use examples; then
+ docinto example
+ dodoc example/*
+ fi
}