summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/vsqlite++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/vsqlite++')
-rw-r--r--dev-db/vsqlite++/Manifest2
-rw-r--r--dev-db/vsqlite++/metadata.xml10
-rw-r--r--dev-db/vsqlite++/vsqlite++-0.3.12.ebuild40
-rw-r--r--dev-db/vsqlite++/vsqlite++-0.3.13-r1.ebuild40
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-db/vsqlite++/Manifest b/dev-db/vsqlite++/Manifest
new file mode 100644
index 000000000000..db7a5164dcbc
--- /dev/null
+++ b/dev-db/vsqlite++/Manifest
@@ -0,0 +1,2 @@
+DIST vsqlite++-0.3.12.tar.gz 23720 SHA256 655d53abe7b21b024111565cf9da8ccaa90540e5ff36d7d227c2eaa22305e925 SHA512 5e134de01a3f2c8adab40ae4f598b5c3b095b7503bf1bcc1aae012d3b087ff68b7cd1fc4dbea74b8cfeac82e9a18428efccea3c1e5a229c2aec05f8228c28344 WHIRLPOOL 66c1252ecc2d05ad2a3690141efe4dace892a839b8b649cbf7b96e55de30bc5d384bd22394d94ca112b0f26380baf6b5db0a6c94d469b9cc5777986e9ae61842
+DIST vsqlite++-0.3.13.tar.gz 28195 SHA256 73dea3c0b4b7769254da17182efbf9fc16893c50ed0d544abfdde127b69467d5 SHA512 70fcd16348e3b2a0854b1d496c68fda7e354068aefbd6a5ad21d7a42afebd2bd746f604240475acfeebe00898ab156f9dfd687346fdf5c77d775262db3a5666e WHIRLPOOL 02d79a14dabbc7a2191f40370d94071c95c4dcb72f4eb6ba68b38872296a92473ddfd06a702bb6862fa2a5eac9ac921dd93e3312615bc587b319cf7a64ee5427
diff --git a/dev-db/vsqlite++/metadata.xml b/dev-db/vsqlite++/metadata.xml
new file mode 100644
index 000000000000..39b2fc42c4fe
--- /dev/null
+++ b/dev-db/vsqlite++/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>graaff@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vinzenz/vsqlite--</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/vsqlite++/vsqlite++-0.3.12.ebuild b/dev-db/vsqlite++/vsqlite++-0.3.12.ebuild
new file mode 100644
index 000000000000..0c1d4099c041
--- /dev/null
+++ b/dev-db/vsqlite++/vsqlite++-0.3.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="VSQLite++ - A welldesigned and portable SQLite3 Wrapper for C++"
+HOMEPAGE="http://evilissimo.fedorapeople.org/releases/vsqlite--/"
+SRC_URI="https://github.com/vinzenz/vsqlite--/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="amd64 ppc x86"
+
+DEPEND=">=dev-libs/boost-1.33.1"
+
+RDEPEND="${DEPEND}
+ dev-db/sqlite:3"
+
+DOCS=(AUTHORS COPYING ChangeLog INSTALL NEWS README TODO VERSION)
+
+# package name is vsqlite++, but github / homepage name is vsqlite--
+S="${WORKDIR}/vsqlite---${PV}"
+
+src_prepare() {
+ ## remove O3 in AM_CXXFLAGS
+ sed -i -e 's/-O3//' Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
diff --git a/dev-db/vsqlite++/vsqlite++-0.3.13-r1.ebuild b/dev-db/vsqlite++/vsqlite++-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..3d4d05d1ef32
--- /dev/null
+++ b/dev-db/vsqlite++/vsqlite++-0.3.13-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="VSQLite++ - A welldesigned and portable SQLite3 Wrapper for C++"
+HOMEPAGE="http://evilissimo.fedorapeople.org/releases/vsqlite--/"
+SRC_URI="https://github.com/vinzenz/vsqlite--/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="static-libs"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="amd64 ~ppc x86"
+
+DEPEND=">=dev-libs/boost-1.33.1"
+
+RDEPEND="${DEPEND}
+ dev-db/sqlite:3"
+
+DOCS=(AUTHORS COPYING ChangeLog INSTALL NEWS README.md TODO VERSION)
+
+# package name is vsqlite++, but github / homepage name is vsqlite--
+S="${WORKDIR}/vsqlite---${PV}"
+
+src_prepare() {
+ ## remove O3 in AM_CXXFLAGS
+ sed -i -e 's/-O3//' Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}