summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-01-27 13:51:39 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-01-27 13:52:24 -0100
commit3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2 (patch)
tree69187b2d47edf9d3836775bc96f5a42f9b021d67 /dev-db
parentnet-irc/znc: sync live ebuild with latest release (diff)
downloadgentoo-3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2.tar.gz
gentoo-3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2.tar.bz2
gentoo-3a44e58d26c24d1d70c84fe4aa1b955d20ce22d2.zip
dev-db/phpmyadmin: security bump to release 4.8.5.
This release addresses advisories PMASA-2019-1 and PMASA-2019-2. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/Manifest1
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index 0765f7984144..838cf2ce3ef0 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,3 +1,4 @@
DIST phpMyAdmin-4.7.8-all-languages.tar.xz 6218056 BLAKE2B 879ef6703711725781fcf3b4c9ab607741c4df0d2f1955f632087e33b599e54128c0811dbd125d9015a0ec597dd6d9af54e7136e91f8637badf698ad7a30b8ba SHA512 ae6edcfba72413a6e0af0b120a99809320a840ab332ae77263f21e14f3b34a38cca70591628ba5818d6732ff6d23551ea51cbf6a75012d2326d0fab1c2a1b9ae
DIST phpMyAdmin-4.8.3-all-languages.tar.xz 5996528 BLAKE2B cf00bab32547c5a6e8c81f529e5b074e3a7c576a7991d6823239172f91cebad7e1b10e2baee589043bf8a5d1d37470a7614a038a0054eaa18e74028bf3cecfd4 SHA512 95998eda6a2db9020671073c62458d819cbd5e54c5f56f467b109401f6b9ebd2dfbc34cc840980bf2d3a7ee3bc93683b7fe20d9bd72b537d8aa066d39089ff89
DIST phpMyAdmin-4.8.4-all-languages.tar.xz 6012216 BLAKE2B 3e6503a7f2d76c6c9e7d8064ef2eb3ea21ee5ef040c0439e24afe9388f8f47aef4fbd8cbe27ae809f45f2c789a289f529a3eda1cf91ef80681d1f76147d753ee SHA512 4f7018416fb925b28d5e061ebba4d99c45497f0e33c6a4bfa32aaa74197a429d61469d8084fd5ea6b23a34444c81905e072b5508f9a87c75e18e0ac596ff2121
+DIST phpMyAdmin-4.8.5-all-languages.tar.xz 6026176 BLAKE2B 6fea778544d266ea9950a5764a6c31806bfcc437edbfd190780218d841e55a21cd534fceef9309d2e1d6acbd8a780cb1d120aeb47e2e35705118ceb9d5ae1266 SHA512 590efd46f4ae5a9cafd3b33f3565d74e4bfd535e3de8763e72da7bccea06fabb2f9fb90af3fe144846573507c5eefc20ee412bf6b51adfb494402302dc81aa2f
diff --git a/dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild b/dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild
new file mode 100644
index 000000000000..b0e6be3d92ed
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-4.8.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+MY_PV=${PV/_/-}
+MY_PN="phpMyAdmin"
+MY_P="${MY_PN}-${MY_PV}-all-languages"
+
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="https://www.phpmyadmin.net/"
+SRC_URI="https://files.phpmyadmin.net/${MY_PN}/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="setup"
+
+RDEPEND="
+ dev-lang/php[ctype,filter,json,session,unicode]
+ || (
+ dev-lang/php[mysqli]
+ dev-lang/php[mysql]
+ )
+ virtual/httpd-php:*
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README RELEASE-DATE-${MY_PV} ChangeLog || die
+ rm -f LICENSE README* RELEASE-DATE-${MY_PV}
+
+ if ! use setup; then
+ rm -rf setup || die "Cannot remove setup utility"
+ elog "The phpMyAdmin setup utility has been removed."
+ elog "It is a regular target of various exploits. If you need it, set USE=setup."
+ else
+ elog "You should consider disabling the setup USE flag"
+ elog "to exclude the setup utility if you don't use it."
+ elog "It regularly is the target of various exploits."
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+ webapp_serverowned "${MY_HTDOCSDIR#${EPREFIX}}"/libraries/config.default.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-3.1.txt
+ webapp_src_install
+}