summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-06-14 10:35:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-06-14 10:35:49 +0000
commit498960800037669a2d7c7f4ea779211fc957f273 (patch)
tree97561b897ed6d6aad4a940b71f574bc1bdb6393d /dev-db
parentsci-mathematics/alectryon: fix distutil calls (diff)
downloadgentoo-498960800037669a2d7c7f4ea779211fc957f273.tar.gz
gentoo-498960800037669a2d7c7f4ea779211fc957f273.tar.bz2
gentoo-498960800037669a2d7c7f4ea779211fc957f273.zip
dev-db/pgpool2: Bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgpool2/Manifest2
-rw-r--r--dev-db/pgpool2/pgpool2-4.2.1-r2.ebuild2
-rw-r--r--dev-db/pgpool2/pgpool2-4.2.2-r2.ebuild2
-rw-r--r--dev-db/pgpool2/pgpool2-4.2.9.ebuild98
-rw-r--r--dev-db/pgpool2/pgpool2-4.3.2.ebuild91
-rw-r--r--dev-db/pgpool2/pgpool2-9999.ebuild2
6 files changed, 194 insertions, 3 deletions
diff --git a/dev-db/pgpool2/Manifest b/dev-db/pgpool2/Manifest
index 870e3b0f5fa9..a7796736bd16 100644
--- a/dev-db/pgpool2/Manifest
+++ b/dev-db/pgpool2/Manifest
@@ -1,3 +1,5 @@
DIST pgpool-II-4.2.1.tar.gz 4713114 BLAKE2B 207cb3c43e47d40385d6808195561117293e5acec6bc34664ec7a1d8754bf9beb8c5350252a4274d4c50520254089f0e5a5fdfc0faf778186fa8000db6124df2 SHA512 b859a3952f69dd98a3df60b33b801d3bc96b9a11757593795a89751abe558c6baab10a37701d69d415c9da26a16abcdc72e0209e74c62204facfb25cdbc512f8
DIST pgpool-II-4.2.2.tar.gz 4734840 BLAKE2B 2b4d26991732293e1411d1219f85a8c9ad1dca72c63069381ae1377a02ae215e813356172f3b89b42b9140549c92c76d443b125bb65cbc6abf03d2b99cf18dab SHA512 a147c810cc691fb27b823a813cbd2eaad66822c7c9f5c0f829cc70d4ac65911bbe827640f2dbd8060913276ed97340b52167e4332e9cdf013b6c9bc144c7b5d8
+DIST pgpool-II-4.2.9.tar.gz 4642836 BLAKE2B 75cfaf86d2e7a4f9677b7d5a98b783e25458e282b682979d31023372dd827dd0b52bf684949e9c97e404c383ab8b2f526e40b00e643d3d6566c702b111a13e34 SHA512 b0256095298e1c1ee50133b4bdc5716aea52f2ab6dc4dc4152ca0415f9b5ccfc14f97d6af1167e69fa1e2b0fd37468a5a10a1cffd8dfcea8e93b11616a66cf42
DIST pgpool-II-4.3.1.tar.gz 6034811 BLAKE2B 6ca2a27eefc2b20186d0e5cbdfd838f429d9996e299ab177e655ed69aa214e676029db728b16020dbdc49d9036fe7aad71d6abb12b486a4cf8fb8348bb201c6c SHA512 a5417d9f5baa1b39e3645f7d44accf0a2f04d5fc5cb4d28089169aaebbd15c20b4cd280d09f15fa764c3b793117086fc03f5d7be584c0c5ff9c5f8e11ddb9ef8
+DIST pgpool-II-4.3.2.tar.gz 5846769 BLAKE2B 82cfe7095ad303ac3a910c533d6e57edb4e3d5b28a9a9bffb2df473dd3087ec329d3a77f9490d9bb738d5d1a443020d96d0e9a1b1d6adecc04cce5d1caa04e7d SHA512 771426257eddb5c48504c80a2c8cccf44a18f7ea50df55654b7e9e017bda561a73a3e1f0db79785785ff6893d6df26f73b55310d0184ef3301838d12290d3d4c
diff --git a/dev-db/pgpool2/pgpool2-4.2.1-r2.ebuild b/dev-db/pgpool2/pgpool2-4.2.1-r2.ebuild
index d34913fcacc3..d3efaa96ffff 100644
--- a/dev-db/pgpool2/pgpool2-4.2.1-r2.ebuild
+++ b/dev-db/pgpool2/pgpool2-4.2.1-r2.ebuild
@@ -56,7 +56,7 @@ src_prepare() {
src_configure() {
postgres-multi_foreach econf \
--disable-rpath \
- --sysconfdir="${EROOT}/etc/${PN}" \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
--with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
--with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
$(use_enable static-libs static) \
diff --git a/dev-db/pgpool2/pgpool2-4.2.2-r2.ebuild b/dev-db/pgpool2/pgpool2-4.2.2-r2.ebuild
index d05f5c5dea0f..c8b5484a0cdb 100644
--- a/dev-db/pgpool2/pgpool2-4.2.2-r2.ebuild
+++ b/dev-db/pgpool2/pgpool2-4.2.2-r2.ebuild
@@ -55,7 +55,7 @@ src_prepare() {
src_configure() {
postgres-multi_foreach econf \
--disable-rpath \
- --sysconfdir="${EROOT}/etc/${PN}" \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
--with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
--with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
$(use_enable static-libs static) \
diff --git a/dev-db/pgpool2/pgpool2-4.2.9.ebuild b/dev-db/pgpool2/pgpool2-4.2.9.ebuild
new file mode 100644
index 000000000000..c2ce05764ea6
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-4.2.9.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( {10..14} )
+
+inherit autotools postgres-multi
+
+MY_P="${PN/2/-II}-${PV}"
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="https://www.pgpool.net/"
+SRC_URI="https://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc memcached pam ssl static-libs"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ net-libs/libnsl:0=
+ virtual/libcrypt:=
+ memcached? ( dev-libs/libmemcached )
+ pam? ( sys-auth/pambase )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ postgres_new_user pgpool
+
+ postgres-multi_pkg_setup
+}
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}/pgpool-4.2.0-configure-memcached.patch" \
+ "${FILESDIR}/pgpool-configure-pam.patch" \
+ "${FILESDIR}/pgpool-4.2.0-configure-pthread.patch" \
+ "${FILESDIR}/pgpool-4.2.0-run_paths.patch"
+
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ postgres-multi_foreach econf \
+ --disable-rpath \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
+ --with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
+ $(use_enable static-libs static) \
+ $(use_with memcached) \
+ $(use_with pam) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ # Even though we're only going to do an install for the best slot
+ # available, the extension bits in src/sql need some things outside
+ # of that directory built, too.
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C src/sql
+}
+
+src_install() {
+ # We only need the best stuff installed
+ postgres-multi_forbest emake DESTDIR="${D}" install
+
+ # Except for the extension and .so files that each PostgreSQL slot needs
+ postgres-multi_foreach emake DESTDIR="${D}" -C src/sql install
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # Documentation!
+ dodoc NEWS TODO
+ doman doc/src/sgml/man{1,8}/*
+ use doc && dodoc -r doc/src/sgml/html
+
+ # mv some files that get installed to /usr/share/pgpool-II so that
+ # they all wind up in the same place
+ mv "${ED}/usr/share/${PN/2/-II}" "${ED}/usr/share/${PN}" || die
+
+ # One more thing: Evil la files!
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-db/pgpool2/pgpool2-4.3.2.ebuild b/dev-db/pgpool2/pgpool2-4.3.2.ebuild
new file mode 100644
index 000000000000..f78d11206305
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-4.3.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+
+inherit autotools postgres-multi
+
+MY_P="${PN/2/-II}-${PV}"
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="https://www.pgpool.net/"
+SRC_URI="https://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc memcached pam ssl static-libs"
+
+RDEPEND="
+ ${POSTGRES_DEP}
+ acct-user/pgpool
+ net-libs/libnsl:0=
+ virtual/libcrypt:=
+ memcached? ( dev-libs/libmemcached )
+ pam? ( sys-auth/pambase )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}/pgpool-4.2.0-configure-memcached.patch" \
+ "${FILESDIR}/pgpool-configure-pam.patch" \
+ "${FILESDIR}/pgpool-4.2.0-configure-pthread.patch" \
+ "${FILESDIR}/pgpool-4.3.1-run_paths.patch"
+
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ postgres-multi_foreach econf \
+ --disable-rpath \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ --with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
+ --with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
+ $(use_enable static-libs static) \
+ $(use_with memcached) \
+ $(use_with pam) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ # Even though we're only going to do an install for the best slot
+ # available, the extension bits in src/sql need some things outside
+ # of that directory built, too.
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C src/sql
+}
+
+src_install() {
+ # We only need the best stuff installed
+ postgres-multi_forbest emake DESTDIR="${D}" install
+
+ # Except for the extension and .so files that each PostgreSQL slot needs
+ postgres-multi_foreach emake DESTDIR="${D}" -C src/sql install
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # Documentation!
+ dodoc NEWS TODO
+ doman doc/src/sgml/man{1,8}/*
+ use doc && dodoc -r doc/src/sgml/html
+
+ # mv some files that get installed to /usr/share/pgpool-II so that
+ # they all wind up in the same place
+ mv "${ED}/usr/share/${PN/2/-II}" "${ED}/usr/share/${PN}" || die
+
+ # One more thing: Evil la files!
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/dev-db/pgpool2/pgpool2-9999.ebuild b/dev-db/pgpool2/pgpool2-9999.ebuild
index 2c9d504b504e..d14481554c21 100644
--- a/dev-db/pgpool2/pgpool2-9999.ebuild
+++ b/dev-db/pgpool2/pgpool2-9999.ebuild
@@ -55,7 +55,7 @@ src_prepare() {
src_configure() {
postgres-multi_foreach econf \
--disable-rpath \
- --sysconfdir="${EROOT}/etc/${PN}" \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
--with-pgsql-includedir='/usr/include/postgresql-@PG_SLOT@' \
--with-pgsql-libdir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/$(get_libdir)" \
$(use_enable static-libs static) \