summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-01-23 14:48:32 -0500
committerBrian Evans <grknight@gentoo.org>2019-01-23 14:48:32 -0500
commit6d1da50b8257d38b280f9719ab9dbc2069884ce5 (patch)
tree56a370ac3e8e5b0894856b3bd283ccd8cfa91df2 /dev-db
parentdev-libs/libisoburn: stable 1.5.0 for sparc, bug #676052 (diff)
downloadgentoo-6d1da50b8257d38b280f9719ab9dbc2069884ce5.tar.gz
gentoo-6d1da50b8257d38b280f9719ab9dbc2069884ce5.tar.bz2
gentoo-6d1da50b8257d38b280f9719ab9dbc2069884ce5.zip
Revert "dev-db/pgadmin3: Remove last rites package"
This reverts commit c27c8dfa1bc0dd1371ce9cd0a1383a44965b0dc9. Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/Manifest1
-rw-r--r--dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch15
-rw-r--r--dev-db/pgadmin3/files/pgadmin3-gcc6-null-pointer.patch11
-rw-r--r--dev-db/pgadmin3/metadata.xml11
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.2.ebuild45
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/Manifest b/dev-db/pgadmin3/Manifest
new file mode 100644
index 000000000000..618d27374287
--- /dev/null
+++ b/dev-db/pgadmin3/Manifest
@@ -0,0 +1 @@
+DIST pgadmin3-1.22.2.tar.gz 14788481 BLAKE2B fd38ae523bfc554138f56a99ee5fe0aaf2446d3b77416552861d4c3d3d939e553ee160264720af3095f91d270b6c719e078ec29b998c2f4a13739ed34c4c0312 SHA512 dcfc72cc2e33dbf1c9d1ce287f9d1d46eb047c99a165372cb74ef1716098f90f2ce2a8d0cd21b511a1ac8c0569dc7b3c0593208a74641f5a8f29dc9c04e40bbd
diff --git a/dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch b/dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch
new file mode 100644
index 000000000000..64a599e00cdb
--- /dev/null
+++ b/dev-db/pgadmin3/files/pgadmin3-desktop-r1.patch
@@ -0,0 +1,15 @@
+diff -Naruw a/pkg/pgadmin3.desktop b/pkg/pgadmin3.desktop
+--- a/pkg/pgadmin3.desktop 2013-02-22 12:21:19.000000000 -0500
++++ b/pkg/pgadmin3.desktop 2015-02-04 15:36:34.845312953 -0500
+@@ -2,9 +2,8 @@
+ Encoding=UTF-8
+ Name=pgAdmin III
+ Exec=/usr/bin/pgadmin3
+-Icon=/usr/share/pgadmin3/pgAdmin3.png
++Icon=/usr/share/pixmaps/pgadmin3.png
+ Type=Application
+-Categories=Application;Development;
+-MimeType=text/html
++Categories=Development;
+ DocPath=/usr/share/pgadmin3/docs/en_US/index.html
+ Comment=PostgreSQL Tools
diff --git a/dev-db/pgadmin3/files/pgadmin3-gcc6-null-pointer.patch b/dev-db/pgadmin3/files/pgadmin3-gcc6-null-pointer.patch
new file mode 100644
index 000000000000..1396f8de8aab
--- /dev/null
+++ b/dev-db/pgadmin3/files/pgadmin3-gcc6-null-pointer.patch
@@ -0,0 +1,11 @@
+--- a/pgadmin/frm/plugins.cpp
++++ b/pgadmin/frm/plugins.cpp
+@@ -380,7 +380,7 @@ bool pluginUtilityFactory::CheckEnable(p
+ {
+ // If we need a specific server type, we can't enable unless
+ // we have a connection.
+- if (!obj || !(obj->GetConnection()->GetStatus() == PGCONN_OK))
++ if (!obj || !obj->GetConnection() || !(obj->GetConnection()->GetStatus() == PGCONN_OK))
+ return false;
+
+ // Get the server type.
diff --git a/dev-db/pgadmin3/metadata.xml b/dev-db/pgadmin3/metadata.xml
new file mode 100644
index 000000000000..7d8a73bc92c1
--- /dev/null
+++ b/dev-db/pgadmin3/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>pgsql-bugs@gentoo.org</email>
+ <name>PostgreSQL and Related Package Development</name>
+ </maintainer>
+<use>
+ <flag name="databasedesigner">Enable the Database Designer component</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
new file mode 100644
index 000000000000..5498f4be6fd3
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.22.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin/pgadmin3/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug +databasedesigner"
+
+DEPEND="
+ x11-libs/wxGTK:3.0=[X]
+ >=dev-db/postgresql-8.4.0:=
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/pgadmin3-{desktop-r1,gcc6-null-pointer}.patch )
+
+src_configure() {
+ WX_GTK_VER="3.0"
+
+ setup-wxwidgets
+
+ econf --with-wx-version=${WX_GTK_VER} \
+ $(use_enable debug) \
+ $(use_enable databasedesigner)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}