summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-02-18 11:39:41 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-02-18 11:40:25 +0300
commit754dfca1c102e23a484f204744ca46b19316a473 (patch)
tree2eaeeff46d72936b0ee47f283df0f51838a53c69 /dev-db
parentdev-db/sqlite: stable 3.21.0 for ia64, bug #641108 (diff)
downloadgentoo-754dfca1c102e23a484f204744ca46b19316a473.tar.gz
gentoo-754dfca1c102e23a484f204744ca46b19316a473.tar.bz2
gentoo-754dfca1c102e23a484f204744ca46b19316a473.zip
dev-db/sqlcipher: version bump
Fix automagic dependency on dev-libs/libedit Reported-by: Andreas Sturmlechner <asturm@gentoo.org> Gentoo-Bug: 634826 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlcipher/Manifest1
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.4.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/Manifest b/dev-db/sqlcipher/Manifest
index 28265b767651..92c76c5bb127 100644
--- a/dev-db/sqlcipher/Manifest
+++ b/dev-db/sqlcipher/Manifest
@@ -1 +1,2 @@
DIST sqlcipher-3.4.1.tar.gz 13873645 BLAKE2B 8d910691fff6d31393a9e4adb549c084472b3f962f46a6ecd9f0860e5ad3c225d1e7bccd1fc4d87fb0641de0091408ef82521718c21e874a622f5304b6a7df08 SHA512 1c08ccdf438c0de23b1293192c687cb869db1ea904c47da5643c69f3a21f3f6a801fe8e87eb2e660acf0fe977b1f05bf8801b79162c609ffa3711706392c642b
+DIST sqlcipher-3.4.2.tar.gz 14743960 BLAKE2B 88ee265b02bb9a42734c2ef93070c8fd8e13d546d7cc85e7fbfd6e6046ccbf2626d75e14b19cbba379c99784c7311d0100de06235b99b4908c60c99890d8d7a2 SHA512 c620bf2b175e404afd60ebe76b5476f5a447ff5fcdfa31bebc3f4bd7f1ebfcd507ee423cd582c9b3d6431d8b57320171492da2586e1a739adb4f440e7443dc03
diff --git a/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild b/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
new file mode 100644
index 000000000000..fce76e2a5797
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="https://www.zetetic.net/sqlcipher/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libedit readline libressl static-libs tcl test"
+
+# Tcl is always needed by buildsystem
+RDEPEND="
+ libedit? ( dev-libs/libedit[${MULTILIB_USEDEP}] )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-lang/tcl:*"
+
+# Libedit and readline support are mutually exclusive
+# Testsuite requires compilation with TCL, bug #582584
+REQUIRED_USE="
+ libedit? ( !readline )
+ test? ( tcl )
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ append-cflags -DSQLITE_HAS_CODEC
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-fts3 \
+ --enable-fts4 \
+ --enable-fts5 \
+ --enable-json1 \
+ --enable-tempstore \
+ $(use_enable libedit editline) \
+ $(use_enable readline) \
+ $(use_enable static-libs static) \
+ $(use_enable tcl)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}