summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-21 20:48:10 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-21 20:49:57 +0200
commit81ae228cb75845a554b9932d4ae60db1083779ed (patch)
tree419691802e691ee8272b5fecd847e2d4106c5ee3 /dev-db
parentsci-calculators/tiemu: Removing tiemu-3.03 (EAPI 4) (diff)
downloadgentoo-81ae228cb75845a554b9932d4ae60db1083779ed.tar.gz
gentoo-81ae228cb75845a554b9932d4ae60db1083779ed.tar.bz2
gentoo-81ae228cb75845a554b9932d4ae60db1083779ed.zip
dev-db/mongodb: Allow for building against boost 1.62
Gentoo-bug: 596222 * Add missing SLOT for libressl dependency Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mongodb/files/mongodb-3.2.10-boost-1.62.patch15
-rw-r--r--dev-db/mongodb/mongodb-3.2.10.ebuild8
2 files changed, 20 insertions, 3 deletions
diff --git a/dev-db/mongodb/files/mongodb-3.2.10-boost-1.62.patch b/dev-db/mongodb/files/mongodb-3.2.10-boost-1.62.patch
new file mode 100644
index 000000000000..30a3bdff45f8
--- /dev/null
+++ b/dev-db/mongodb/files/mongodb-3.2.10-boost-1.62.patch
@@ -0,0 +1,15 @@
+Derived from http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/databases/mongodb/patches/patch-src_mongo_db_fts_unicode_string.cpp v1.1
+
+* Fix build with boost 1.62.0
+
+--- a/src/mongo/db/fts/unicode/string.cpp 2016-09-26 12:10:04.000000000 +0000
++++ b/src/mongo/db/fts/unicode/string.cpp
+@@ -274,7 +274,7 @@ bool String::substrMatch(const std::stri
+
+ // Case sensitive and diacritic sensitive.
+ return boost::algorithm::boyer_moore_search(
+- haystack.begin(), haystack.end(), needle.begin(), needle.end()) != haystack.end();
++ haystack.begin(), haystack.end(), needle.begin(), needle.end()) != std::make_pair(haystack.end(), haystack.end());
+ }
+
+ } // namespace unicode
diff --git a/dev-db/mongodb/mongodb-3.2.10.ebuild b/dev-db/mongodb/mongodb-3.2.10.ebuild
index 15b346cad3be..00c9f2a9eb0e 100644
--- a/dev-db/mongodb/mongodb-3.2.10.ebuild
+++ b/dev-db/mongodb/mongodb-3.2.10.ebuild
@@ -31,7 +31,7 @@ RDEPEND=">=app-arch/snappy-1.1.2
mms-agent? ( app-admin/mms-agent )
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.1g:0= )
- libressl? ( dev-libs/libressl:= )
+ libressl? ( dev-libs/libressl:0= )
)"
DEPEND="${RDEPEND}
>=sys-devel/gcc-4.8.2:*
@@ -101,8 +101,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-3.2.0-fix-scons.patch" \
- "${FILESDIR}/${PN}-3.2.4-boost-1.60.patch"
+ epatch \
+ "${FILESDIR}/${PN}-3.2.0-fix-scons.patch" \
+ "${FILESDIR}/${PN}-3.2.4-boost-1.60.patch" \
+ "${FILESDIR}/${PN}-3.2.10-boost-1.62.patch"
epatch_user
}