summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-03-29 01:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2021-03-29 13:42:35 -0400
commitb2b164ba52c04ff6fb7b8879d35f0f08ee01aed9 (patch)
tree6e548cf5e8a258370e87a5a3f988b6bf72965d61 /dev-db
parentdev-db/sqlite: Version bump (3.35.3). (diff)
downloadgentoo-b2b164ba52c04ff6fb7b8879d35f0f08ee01aed9.tar.gz
gentoo-b2b164ba52c04ff6fb7b8879d35f0f08ee01aed9.tar.bz2
gentoo-b2b164ba52c04ff6fb7b8879d35f0f08ee01aed9.zip
dev-db/sqlite: Fix Tcl dependency and detection.
Fixes: f797e0fd4092a1d9e83c23005806a2db3d7bd0c2 Bug: https://bugs.gentoo.org/724578 Closes: https://bugs.gentoo.org/773967 Closes: https://github.com/gentoo/gentoo/pull/19972 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/sqlite-3.33.0.ebuild11
-rw-r--r--dev-db/sqlite/sqlite-3.34.0.ebuild11
-rw-r--r--dev-db/sqlite/sqlite-3.34.1.ebuild11
-rw-r--r--dev-db/sqlite/sqlite-3.35.0.ebuild11
-rw-r--r--dev-db/sqlite/sqlite-3.35.1.ebuild11
-rw-r--r--dev-db/sqlite/sqlite-3.35.2.ebuild11
-rw-r--r--dev-db/sqlite/sqlite-3.35.3.ebuild11
7 files changed, 63 insertions, 14 deletions
diff --git a/dev-db/sqlite/sqlite-3.33.0.ebuild b/dev-db/sqlite/sqlite-3.33.0.ebuild
index 1237bba34ff1..2ce5d1d4506e 100644
--- a/dev-db/sqlite/sqlite-3.33.0.ebuild
+++ b/dev-db/sqlite/sqlite-3.33.0.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -274,7 +274,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.
diff --git a/dev-db/sqlite/sqlite-3.34.0.ebuild b/dev-db/sqlite/sqlite-3.34.0.ebuild
index 3e24d1239bef..e9d419d08e71 100644
--- a/dev-db/sqlite/sqlite-3.34.0.ebuild
+++ b/dev-db/sqlite/sqlite-3.34.0.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -311,7 +311,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.
diff --git a/dev-db/sqlite/sqlite-3.34.1.ebuild b/dev-db/sqlite/sqlite-3.34.1.ebuild
index 24baff37d525..623578707fa3 100644
--- a/dev-db/sqlite/sqlite-3.34.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.34.1.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -311,7 +311,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.
diff --git a/dev-db/sqlite/sqlite-3.35.0.ebuild b/dev-db/sqlite/sqlite-3.35.0.ebuild
index d04438ce2cb9..e1762793c342 100644
--- a/dev-db/sqlite/sqlite-3.35.0.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.0.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -311,7 +311,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.
diff --git a/dev-db/sqlite/sqlite-3.35.1.ebuild b/dev-db/sqlite/sqlite-3.35.1.ebuild
index d04438ce2cb9..e1762793c342 100644
--- a/dev-db/sqlite/sqlite-3.35.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.1.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -311,7 +311,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.
diff --git a/dev-db/sqlite/sqlite-3.35.2.ebuild b/dev-db/sqlite/sqlite-3.35.2.ebuild
index d04438ce2cb9..e1762793c342 100644
--- a/dev-db/sqlite/sqlite-3.35.2.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.2.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -311,7 +311,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.
diff --git a/dev-db/sqlite/sqlite-3.35.3.ebuild b/dev-db/sqlite/sqlite-3.35.3.ebuild
index d04438ce2cb9..e1762793c342 100644
--- a/dev-db/sqlite/sqlite-3.35.3.ebuild
+++ b/dev-db/sqlite/sqlite-3.35.3.ebuild
@@ -40,7 +40,7 @@ RDEPEND="sys-libs/zlib:0=[${MULTILIB_USEDEP}]
icu? ( dev-libs/icu:0=[${MULTILIB_USEDEP}] )
readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
tcl? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )
- tools? ( dev-lang/tcl:0=[${MULTILIB_USEDEP}] )"
+ tools? ( dev-lang/tcl:0= )"
DEPEND="${RDEPEND}
test? ( >=dev-lang/tcl-8.6:0[${MULTILIB_USEDEP}] )"
@@ -311,7 +311,14 @@ multilib_src_configure() {
options+=($(use_enable static-libs static))
# tcl, test, tools USE flags.
- options+=(--enable-tcl)
+ if use tcl || use test || { use tools && multilib_is_native_abi; }; then
+ options+=(
+ --enable-tcl
+ --with-tcl="${ESYSROOT}/usr/$(get_libdir)"
+ )
+ else
+ options+=(--disable-tcl)
+ fi
if [[ "${CHOST}" == *-mint* ]]; then
# sys/mman.h not available in MiNTLib.