summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-04-25 20:59:04 +0200
committerMike Gilbert <floppym@gentoo.org>2018-04-26 11:12:17 -0400
commitb5bd242b0ee5b96c7fe39c765caf261c1a674088 (patch)
tree18c1388468c917a2b01d605d5751008e3ef5717a /dev-db
parentx11-misc/synergy: Depend on >=dev-cpp/gtest-1.8.0. (diff)
downloadgentoo-b5bd242b0ee5b96c7fe39c765caf261c1a674088.tar.gz
gentoo-b5bd242b0ee5b96c7fe39c765caf261c1a674088.tar.bz2
gentoo-b5bd242b0ee5b96c7fe39c765caf261c1a674088.zip
dev-db/sqlite: Fix zipfile2-2.0 test on some filesystems.
Closes: https://bugs.gentoo.org/653450
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/files/sqlite-3.23.1-full_archive-tests.patch27
-rw-r--r--dev-db/sqlite/sqlite-3.23.1.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.23.1-full_archive-tests.patch b/dev-db/sqlite/files/sqlite-3.23.1-full_archive-tests.patch
new file mode 100644
index 000000000000..7237fbfc0f30
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.23.1-full_archive-tests.patch
@@ -0,0 +1,27 @@
+https://sqlite.org/src/info/893e6089c875e947
+
+--- /test/zipfile2.test
++++ /test/zipfile2.test
+@@ -52,17 +52,15 @@
+ CREATE VIRTUAL TABLE fff USING zipfile('test''zip');
+ }
+
+-if {$::tcl_platform(platform)=="windows"} {
+- set res {1 {cannot open file: testdir}}
+-} else {
+- set res {1 {error in fread()}}
+-}
+ do_test 2.0 {
+ forcedelete testdir
+ file mkdir testdir
+ execsql { CREATE VIRTUAL TABLE hhh USING zipfile('testdir') }
+- catchsql { SELECT * FROM hhh }
+-} $res
++ lindex [catchsql {
++ SELECT * FROM hhh;
++ INSERT INTO hhh(name, data) VALUES('1.txt', 'file data');
++ }] 0
++} 1
+
+
+ set archive {
diff --git a/dev-db/sqlite/sqlite-3.23.1.ebuild b/dev-db/sqlite/sqlite-3.23.1.ebuild
index 863c3cd57b6c..88f7d9dfd71e 100644
--- a/dev-db/sqlite/sqlite-3.23.1.ebuild
+++ b/dev-db/sqlite/sqlite-3.23.1.ebuild
@@ -52,6 +52,7 @@ src_prepare() {
if full_archive; then
eapply "${FILESDIR}/${PN}-3.23.0-full_archive-build.patch"
eapply "${FILESDIR}/${PN}-3.23.1-full_archive-prohibit_bound_parameters_in_arguments_to_table-valued_functions_within_triggers.patch"
+ eapply "${FILESDIR}/${PN}-3.23.1-full_archive-tests.patch"
eapply_user