summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-30 13:11:34 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-30 12:28:08 +0300
commitcec23a51a1433ef3fecd0c98b13e95ac96891e4b (patch)
tree72f5ebd56a2e2e8af48bf153b068ebb6cb220e68 /dev-db
parentdev-python/pytools-2020.4: stabilise on amd64 (diff)
downloadgentoo-cec23a51a1433ef3fecd0c98b13e95ac96891e4b.tar.gz
gentoo-cec23a51a1433ef3fecd0c98b13e95ac96891e4b.tar.bz2
gentoo-cec23a51a1433ef3fecd0c98b13e95ac96891e4b.zip
dev-db/pgcli: bump to 3.0.0
Closes: https://bugs.gentoo.org/735922 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgcli/Manifest1
-rw-r--r--dev-db/pgcli/pgcli-3.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-db/pgcli/Manifest b/dev-db/pgcli/Manifest
index 2c4c260a70e5..6db8480edc11 100644
--- a/dev-db/pgcli/Manifest
+++ b/dev-db/pgcli/Manifest
@@ -1 +1,2 @@
DIST pgcli-2.2.0.tar.gz 436991 BLAKE2B 9041240952a8ba9a770705850bf4281eaa89ac5b970366c7ec27e705bec65d9c3c455fb2c9d2220d53f4a9ff31142501437faa6974839f6fe59e6fc1618d8a6d SHA512 239a3278b604248b7bd5cdaf4d0b0f3e62188617b04c358d123e2fa2ad1449c3854ef84995b89239fcf559ce010ee0dd80e12ddd72b27dcb89f92ac08d34c49b
+DIST pgcli-3.0.0.tar.gz 437733 BLAKE2B 5db69997f675812c3ef847b220b66e7872b134b4d8debd668154bdfa6020432ac08829e7c2ce42adc4cf124e84de5eb9aacbe19636216502f81373a71f21b68f SHA512 7ac52cbfc492dc85163dac7df7a5dde6bfa0327ac1ef6580891cb76d617b998d74c2a59b27d2f8abf8699eb5a69aba30bf13e95ad7bee75c83350730ac061262
diff --git a/dev-db/pgcli/pgcli-3.0.0.ebuild b/dev-db/pgcli/pgcli-3.0.0.ebuild
new file mode 100644
index 000000000000..ea2e13b936ea
--- /dev/null
+++ b/dev-db/pgcli/pgcli-3.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
+HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
+SRC_URI="https://github.com/dbcli/pgcli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/prompt_toolkit-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/prompt_toolkit-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/sqlparse-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cli_helpers-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/humanize-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/pgspecial-1.11.8[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.1.9[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ test? (
+ dev-db/postgresql
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest