summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild')
-rw-r--r--dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild b/dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild
new file mode 100644
index 000000000000..69be319ba493
--- /dev/null
+++ b/dev-dotnet/ikvm/ikvm-0.46.0.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils mono multilib java-pkg-2
+
+DESCRIPTION="Java VM for .NET"
+HOMEPAGE="http://www.ikvm.net/ http://weblog.ikvm.net/"
+SRC_URI="http://www.frijters.net/openjdk6-b22-stripped.zip
+ http://www.frijters.net/${PN}src-${PV}.zip"
+LICENSE="ZLIB GPL-2-with-linking-exception"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2
+ dev-libs/glib"
+DEPEND="${RDEPEND}
+ !dev-dotnet/ikvm-bin
+ >=dev-dotnet/nant-0.85
+ >=virtual/jdk-1.6
+ app-arch/unzip
+ virtual/pkgconfig
+ app-arch/sharutils"
+
+src_prepare() {
+ # We cannot rely on Mono Crypto Service Provider as it doesn't work inside
+ # sandbox, we simply hard-code the path to a bundled key like Debian does.
+ epatch "${FILESDIR}"/${PN}-0.46.0.1-key.patch
+ uudecode < "${FILESDIR}"/mono.snk.uu || die
+
+ # Ensures that we use Mono's bundled copy of SharpZipLib instead of relying
+ # on ikvm-bin one
+ sed -i -e 's:../bin/ICSharpCode.SharpZipLib.dll:ICSharpCode.SharpZipLib.dll:' \
+ ikvmc/ikvmc.build ikvmstub/ikvmstub.build || die
+
+ sed -i -e 's:pkg-config --cflags:pkg-config --cflags --libs:' \
+ native/native.build || die
+
+ mkdir -p "${T}"/home/test
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ XDG_CONFIG_HOME="${T}/home/test" nant -t:mono-2.0 signed || die "ikvm build failed"
+}
+
+generate_pkgconfig() {
+ ebegin "Generating .pc file"
+ local dll LSTRING="Libs:"
+ dodir "/usr/$(get_libdir)/pkgconfig"
+ cat <<- EOF -> "${D}/usr/$(get_libdir)/pkgconfig/${PN}.pc"
+ prefix=/usr
+ exec_prefix=\${prefix}
+ libdir=\${prefix}/$(get_libdir)
+ Name: IKVM.NET
+ Description: An implementation of Java for Mono and the Microsoft .NET Framework.
+ Version: ${PV}
+ EOF
+ for dll in "${S}"/bin/IKVM.*.dll
+ do
+ LSTRING="${LSTRING} -r:"'${libdir}'"/mono/IKVM/${dll##*/}"
+ done
+ printf "${LSTRING}" >> "${D}/usr/$(get_libdir)/pkgconfig/${PN}.pc"
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --silence-errors --libs ikvm &> /dev/null
+ eend $?
+}
+
+src_install() {
+ local dll dllbase exe
+ insinto /usr/$(get_libdir)/${PN}
+ doins bin/*.exe
+
+ dodir /bin
+ for exe in bin/*.exe
+ do
+ exebase=${exe##*/}
+ ebegin "Generating wrapper for ${exebase} -> ${exebase%.exe}"
+ make_wrapper ${exebase%.exe} "mono /usr/$(get_libdir)/${PN}/${exebase}"
+ eend $? || die "Failed generating wrapper for ${exebase}"
+ done
+
+ generate_pkgconfig || die "generating .pc failed"
+
+ for dll in bin/IKVM.*.dll
+ do
+ dllbase=${dll##*/}
+ ebegin "Installing and registering ${dllbase}"
+ gacutil -i bin/${dllbase} -root "${D}"/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package IKVM &>/dev/null
+ eend $? || die "Failed installing ${dllbase}"
+ done
+}