summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-08-20 15:10:34 +0300
committerStefan Strogin <steils@gentoo.org>2019-08-20 15:10:42 +0300
commit8601f2c99c0468872c49a70aa2dab55892f79f5f (patch)
treecceaded8ef9247336c8575f3b460d6af19088d45 /dev-dotnet/libgdiplus
parentdev-util/sysdig: Bump to 0.26.3 (diff)
downloadgentoo-8601f2c99c0468872c49a70aa2dab55892f79f5f.tar.gz
gentoo-8601f2c99c0468872c49a70aa2dab55892f79f5f.tar.bz2
gentoo-8601f2c99c0468872c49a70aa2dab55892f79f5f.zip
dev-dotnet/libgdiplus: bump version to 6.0.2
Closes: https://bugs.gentoo.org/609760 Closes: https://bugs.gentoo.org/682068 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'dev-dotnet/libgdiplus')
-rw-r--r--dev-dotnet/libgdiplus/Manifest1
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-dotnet/libgdiplus/Manifest b/dev-dotnet/libgdiplus/Manifest
index f90aac9f1920..b8df1fe8aacd 100644
--- a/dev-dotnet/libgdiplus/Manifest
+++ b/dev-dotnet/libgdiplus/Manifest
@@ -1,3 +1,4 @@
DIST libgdiplus-2.10.9.tar.bz2 2074317 BLAKE2B ddbdc22d61734e9141f7d05b45867b1c0ac89903a74d23a3b05d247913aaac5350a603a5d7acb85338b2e9877b077c3c4b43839b33b2f6507b76035124cb43b4 SHA512 7f1944795c7ede5fd92a6d7e8d7d6cf2ef3c154e656b83e769b417f8f7195dd975084afe3c3cd1dda1ecb2c1167f76c0b5714cd16d549ff056add09763c6b26c
DIST libgdiplus-4.2.tar.gz 687398 BLAKE2B e9b5912cb63de9692861b09ceeb5ad55fa6999960fddbbe55382f957591e68bede91550c2d49ed4bc78d118288ca6b35a2b2ab69f87f9fcc289b7fe2b1853b7a SHA512 102d1e07a106fa32640a20c4843bf82b3f628c5b7a3813d39c7712f2cd09d80dc5adb337a8d5bdbae065f876a0c433a5d8fcb7d761dff5ee08c48cac2cd2344e
DIST libgdiplus-5.6.1.tar.gz 734255 BLAKE2B db54559b6bb6ea3f3f966de8692f08c4a042d0719b45263d3f546be1c7795a86d26943d699284acded8419a969238f58f2482090186df1b167d650343900729d SHA512 f1e477e4cbdd83f15bd8edc0feb975399c3eca042cafd1795a018f412b88ad5eb82d2cb0852d2009fdaa6f17d1c62c6b81340578f00eccc2e98ac9debe4a748e
+DIST libgdiplus-6.0.2.tar.gz 1377140 BLAKE2B 5c639a14371eadee0bfa2ad135284089c65212bde0909d21af8f80fd5bdf7283a8aa688ed88df374a0eac0696a377ba05419b12d9a93b37550c020d2b9961ee0 SHA512 b334846cf9471e6f81a3e0a2d6b68c9a39f52e6b22833432e34d3823ae12e3aa9d481806ea9a078463a77f56f3265633447d6709c5ade86ea117d3690f16472c
diff --git a/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild b/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild
new file mode 100644
index 000000000000..4c37480bf4c9
--- /dev/null
+++ b/dev-dotnet/libgdiplus/libgdiplus-6.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit dotnet
+
+DESCRIPTION="Library for using System.Drawing with Mono"
+HOMEPAGE="https://www.mono-project.com"
+SRC_URI="https://download.mono-project.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cairo"
+#skip tests due https://bugs.gentoo.org/687784
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib
+ media-libs/freetype
+ media-libs/fontconfig
+ >=media-libs/giflib-5.1.2
+ media-libs/libexif
+ media-libs/libpng:0=
+ media-libs/tiff
+ x11-libs/cairo[X]
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ virtual/jpeg:0
+ !cairo? ( x11-libs/pango )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(usex cairo "" "--with-pango")
+}
+
+src_install () {
+ default
+
+ dotnet_multilib_comply
+ local commondoc=( AUTHORS ChangeLog README TODO )
+ for docfile in "${commondoc[@]}"; do
+ [[ -e "${docfile}" ]] && dodoc "${docfile}"
+ done
+ [[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
+ prune_libtool_files
+}