summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-10 12:30:01 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 12:38:51 +0100
commit17f9a49e397ca809776a75639628574704189bbf (patch)
treea69ea3ea9c3ad1bf5cbb79a0779df722af628415 /dev-dotnet
parentnet-fs/curlftpfs: drop old (diff)
downloadgentoo-17f9a49e397ca809776a75639628574704189bbf.tar.gz
gentoo-17f9a49e397ca809776a75639628574704189bbf.tar.bz2
gentoo-17f9a49e397ca809776a75639628574704189bbf.zip
dev-dotnet/monocalendar: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697366 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
index a14d50d57957..4837debd2b9f 100644
--- a/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
+++ b/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit mono eutils multilib
-
-S="${WORKDIR}/MonoCalendar"
+inherit eutils mono
DESCRIPTION="iCal clone for .NET"
HOMEPAGE="http://www.monocalendar.com/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+S="${WORKDIR}/MonoCalendar"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
@@ -20,17 +19,13 @@ DEPEND=">=dev-lang/mono-1.2.1"
RDEPEND="${DEPEND}"
src_compile() {
- cd "${S}"/bin/Release/
-
- emake || die "emake failed"
+ emake -C bin/Release
}
src_install() {
- dodir /usr/$(get_libdir)/${PN}
- insinto /usr/$(get_libdir)/${PN}
-
- doins bin/Release/*dll
- doins bin/Release/*.exe
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/Release/*dll
+ doexe bin/Release/*.exe
make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
}