summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/gnap-ext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/gnap-ext')
-rw-r--r--dev-embedded/gnap-ext/Manifest3
-rw-r--r--dev-embedded/gnap-ext/gnap-ext-2.0.ebuild40
-rw-r--r--dev-embedded/gnap-ext/metadata.xml7
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-embedded/gnap-ext/Manifest b/dev-embedded/gnap-ext/Manifest
new file mode 100644
index 000000000000..49e1b74e9d1d
--- /dev/null
+++ b/dev-embedded/gnap-ext/Manifest
@@ -0,0 +1,3 @@
+DIST gnap-basefs-2.0.tar.bz2 8689764 SHA256 2611fb11442ced916966b7f57927114ba993bbe258e89424242bc427473acf69 SHA512 84a208197d6f5bee42f07eb1f4a02d3d64a4e938e51c7aaa503729ef40f8d7847de2563676e7a14c35fc381905b9da45e89357283060c75c997f3ff52049abeb WHIRLPOOL 49173ded09c98ddafcb25918d16f49995dc7c5062c8ec2316c070d96e9386a82b84245a591b8d06eab2f3cff745435a99f06bf7b1df11d36695ad94144e981cb
+DIST gnap-extensions-2.0.tar 1198080 SHA256 905bba34a307f94ff63fa9c9eac5c7fad31b15ca2471bfd47a78a59bb2028995 SHA512 08266d2b71fd1f170e9ae01fa9c0b3fa898dde7220b1b1d9828fa4bc51b08bcb5af4c7eab75eabc3b3c110ff3e24b2fd193ab36b5579b2507da1a09a90bd4044 WHIRLPOOL 731a47c321a10ee0419e3de21befc473b90cb535616ae542a82a3a6089036a8c24a83d4d243c6fb50e40c59513e5d110ed8630dc3c7ffed1015af3380e7b1cc7
+DIST gnap-tools-2.0.tar.bz2 26874 SHA256 925083618f6d19d70b0c3d4236a374ea1ea72abb1ee7999973b653751bda4a6b SHA512 cd8de371aaeee9b5dac5bebb4961855e78cd173a1de99056671e0071be2376c3fd45fb7d635786ad22f3ff413fbcd6d2b710b7c8ca4e99bdfbb09b31e7bf4b52 WHIRLPOOL eb5434a7ca3ac1f7ff5f3d2377a771e865600085d957287892eb0648cd4c3dac7101bff4e144d80197de9b4acd1455e0f59fdaead51e4a1d8a515a01ab4c5477
diff --git a/dev-embedded/gnap-ext/gnap-ext-2.0.ebuild b/dev-embedded/gnap-ext/gnap-ext-2.0.ebuild
new file mode 100644
index 000000000000..2084a68c390c
--- /dev/null
+++ b/dev-embedded/gnap-ext/gnap-ext-2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="${P/gnap-ext/gnap-tools}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Gentoo-based Network Appliance extensions and remastering tool"
+HOMEPAGE="http://embedded.gentoo.org/gnap.xml"
+
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+ !minimal? ( mirror://gentoo/gnap-basefs-${PV}.tar.bz2
+ mirror://gentoo/gnap-extensions-${PV}.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="minimal"
+
+RDEPEND="sys-fs/squashfs-tools"
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ if ! use minimal; then
+ unpack gnap-extensions-${PV}.tar
+ fi
+}
+
+src_install() {
+ dobin gnap_remaster
+ doman gnap_remaster.1
+
+ if ! use minimal; then
+ dodir /usr/lib/gnap
+ insinto /usr/lib/gnap
+ newins ${DISTDIR}/gnap-basefs-${PV}.tar.bz2 gnap-basefs.tar.bz2
+ dodir /usr/lib/gnap/extensions
+ insinto /usr/lib/gnap/extensions
+ doins ${WORKDIR}/gnapext_*.tbz2
+ fi
+}
diff --git a/dev-embedded/gnap-ext/metadata.xml b/dev-embedded/gnap-ext/metadata.xml
new file mode 100644
index 000000000000..2d5a14582e95
--- /dev/null
+++ b/dev-embedded/gnap-ext/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gnap@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>