summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-27 20:27:08 +0000
committerSam James <sam@gentoo.org>2020-12-27 20:27:08 +0000
commit41bac712cea316ecee57dd1b14cb01f607346d28 (patch)
treeced7f84ab6093a42cd3e4a91103e2d7144f55ad2 /dev-embedded/libftdi
parentdev-embedded/libftdi: support Python 3.7+ in slot 0 (diff)
downloadgentoo-41bac712cea316ecee57dd1b14cb01f607346d28.tar.gz
gentoo-41bac712cea316ecee57dd1b14cb01f607346d28.tar.bz2
gentoo-41bac712cea316ecee57dd1b14cb01f607346d28.zip
dev-embedded/libftdi: add missing tests patch to :1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/files/libftdi-1.5-tests-no-cxx.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-embedded/libftdi/files/libftdi-1.5-tests-no-cxx.patch b/dev-embedded/libftdi/files/libftdi-1.5-tests-no-cxx.patch
new file mode 100644
index 000000000000..6adba408f7f1
--- /dev/null
+++ b/dev-embedded/libftdi/files/libftdi-1.5-tests-no-cxx.patch
@@ -0,0 +1,35 @@
+Fixes failure to build tests with USE="-cxx" (default).
+http://developer.intra2net.com/git/?p=libftdi;a=patch;h=11a50ae5b80b3e03694a19e84513345d0794e563;hp=6dd18122a81e6030dd239391df6ffde8cb8c59c7
+From 11a50ae5b80b3e03694a19e84513345d0794e563 Mon Sep 17 00:00:00 2001
+From: Thomas Jarosch <thomas.jarosch@intra2net.com>
+Date: Mon, 24 Aug 2020 19:27:22 +0200
+Subject: [PATCH 1/1] Fix building unit tests without FTDIPP
+
+Needed to run the baudrate unit tests.
+
+Probably another fallout from:
+
+****************************
+commit 0209a3633dc877a577af07d883eb5059e22f6a91
+
+cmake: do not check for g++ when FTDIPP is disabled
+****************************
+---
+ CMakeLists.txt | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3b0b87c..58f664a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -150,6 +150,7 @@ if ( EXAMPLES )
+ endif ()
+ add_subdirectory(packages)
+ if ( BUILD_TESTS )
++ project(libftdi1 C CXX)
+ add_subdirectory(test)
+ endif ()
+
+--
+1.7.1
+