summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-27 19:50:10 +0000
committerSam James <sam@gentoo.org>2020-12-27 20:19:33 +0000
commitec756fc35c98d20a36e8a239612998148a7b9e29 (patch)
treeb6c8e598d070a132bab20634175a31c1755cef41 /dev-embedded/libftdi
parentsys-apps/dbus: drop sysusers.d file (diff)
downloadgentoo-ec756fc35c98d20a36e8a239612998148a7b9e29.tar.gz
gentoo-ec756fc35c98d20a36e8a239612998148a7b9e29.tar.bz2
gentoo-ec756fc35c98d20a36e8a239612998148a7b9e29.zip
dev-embedded/libftdi: bump to 1.5
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded/libftdi')
-rw-r--r--dev-embedded/libftdi/Manifest1
-rw-r--r--dev-embedded/libftdi/libftdi-1.5.ebuild85
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild29
3 files changed, 106 insertions, 9 deletions
diff --git a/dev-embedded/libftdi/Manifest b/dev-embedded/libftdi/Manifest
index 4f82f27ba19b..d47dc505633a 100644
--- a/dev-embedded/libftdi/Manifest
+++ b/dev-embedded/libftdi/Manifest
@@ -1,2 +1,3 @@
DIST libftdi-0.20.tar.gz 423570 BLAKE2B f0aa420a704e18c4257b99a4593dbaf46a15806d980b24909fe8678b36e74b568cd5915db1e14f8b904541334fbf3d18f069dc479a0bf66b2ea8e113611cb82b SHA512 540e5eb201a65936c3dbabff70c251deba1615874b11ff27c5ca16c39d71c150cf61758a68b541135a444fe32ab403b0fba0daf55c587647aaf9b3f400f1dee7
DIST libftdi1-1.4.tar.bz2 109521 BLAKE2B 4186342afb2a0118c454230a925ccff2ed0aedd942cdd3afb1ac59519f1cd48db7f04421ecdb5aa6e53993666a903de00ce447fd81d00839806f8cc0d34c6e52 SHA512 dbab74f7bc35ca835b9c6dd5b70a64816948d65da1f73a9ece37a0f0f630bd0df1a676543acc517b02a718bc34ba4f7a30cbc48b6eed1c154c917f8ef0a358fc
+DIST libftdi1-1.5.tar.bz2 116297 BLAKE2B 460ab93026e14a452e31fcc6930d305638fdc0ed06cb44fb9d50ad8f80199b17057d2f48a27b8295b43b956934289c872a2ef1ddb7f93fa93c6816511ef7607d SHA512 c525b2ab6aff9ef9254971ae7d57f3549a36a36875765c48f947d52532814a2a004de1232389d4fe824a8c8ab84277b08427308573476e1da9b7db83db802f6f
diff --git a/dev-embedded/libftdi/libftdi-1.5.ebuild b/dev-embedded/libftdi/libftdi-1.5.ebuild
new file mode 100644
index 000000000000..78362696c2ec
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-1.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit cmake python-single-r1
+
+MY_P="${PN}1-${PV}"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
+else
+ SRC_URI="https://www.intra2net.com/en/developer/${PN}/download/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="https://www.intra2net.com/en/developer/libftdi/"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2"
+SLOT="1"
+IUSE="cxx doc examples python static-libs test tools"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )
+"
+RDEPEND="virtual/libusb:1
+ cxx? ( dev-libs/boost )
+ python? ( ${PYTHON_DEPS} )
+ tools? (
+ !<dev-embedded/ftdi_eeprom-1.0
+ dev-libs/confuse:=
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tests-no-cxx.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFTDIPP=$(usex cxx)
+ -DDOCUMENTATION=$(usex doc)
+ -DEXAMPLES=$(usex examples)
+ -DPYTHON_BINDINGS=$(usex python)
+ -DSTATICLIBS=$(usex static-libs)
+ -DBUILD_TESTS=$(usex test)
+ -DFTDI_EEPROM=$(usex tools)
+ -DCMAKE_SKIP_BUILD_RPATH=ON
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./test_libftdi1 -l all || die
+}
+
+src_install() {
+ cmake_src_install
+ use python && python_optimize
+ dodoc AUTHORS ChangeLog README TODO
+
+ if use doc ; then
+ # Clean up crap man pages. #356369
+ rm -vf "${CMAKE_BUILD_DIR}"/doc/man/man3/_* || die
+
+ doman "${CMAKE_BUILD_DIR}"/doc/man/man3/*
+ dodoc -r "${CMAKE_BUILD_DIR}"/doc/html
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index a85450a924cf..4ad4a4e4baf1 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
if [[ ${PV} == 9999* ]] ; then
@@ -17,6 +17,7 @@ fi
DESCRIPTION="Userspace access to FTDI USB interface chips"
HOMEPAGE="https://www.intra2net.com/en/developer/libftdi/"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2"
SLOT="1"
@@ -24,6 +25,10 @@ IUSE="cxx doc examples python static-libs test tools"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )
+"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
python? ( ${PYTHON_DEPS} )
@@ -31,16 +36,16 @@ RDEPEND="virtual/libusb:1
!<dev-embedded/ftdi_eeprom-1.0
dev-libs/confuse:=
)"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/libftdi-1.5-cmake-git.patch"
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
}
-S=${WORKDIR}/${MY_P}
-
src_configure() {
local mycmakeargs=(
-DFTDIPP=$(usex cxx)
@@ -52,11 +57,16 @@ src_configure() {
-DFTDI_EEPROM=$(usex tools)
-DCMAKE_SKIP_BUILD_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./test_libftdi1 -l all || die
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use python && python_optimize
dodoc AUTHORS ChangeLog README TODO
@@ -67,6 +77,7 @@ src_install() {
doman "${CMAKE_BUILD_DIR}"/doc/man/man3/*
dodoc -r "${CMAKE_BUILD_DIR}"/doc/html
fi
+
if use examples ; then
docinto examples
dodoc examples/*.c