summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/pk2cmd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/pk2cmd')
-rw-r--r--dev-embedded/pk2cmd/Manifest1
-rw-r--r--dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file-1.20.patch16
-rw-r--r--dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch17
-rw-r--r--dev-embedded/pk2cmd/metadata.xml12
-rw-r--r--dev-embedded/pk2cmd/pk2cmd-1.20.ebuild50
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-embedded/pk2cmd/Manifest b/dev-embedded/pk2cmd/Manifest
new file mode 100644
index 000000000000..1f98ccbc1147
--- /dev/null
+++ b/dev-embedded/pk2cmd/Manifest
@@ -0,0 +1 @@
+DIST pk2cmdv1.20LinuxMacSource.tar.gz 223175 SHA256 903027de5036eda3a648decece4acfcefe91e754ef0d4eacba0e5ba8b18857fa SHA512 72675eb287c1410c82ff49b4922afd28a8017b4e8517d10e77e0f0b111630f90881f778d754a47c97453f45412e965e281435d495fc70a047bd7357dd64f7b24 WHIRLPOOL f4f36412d4e653a20866bcbe9ec25b94e8ff4e75c1ae2e4944a42682832c9b64b683248bc559e73b976902906d2959492867f055291588cf66d9b83838174c75
diff --git a/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file-1.20.patch b/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file-1.20.patch
new file mode 100644
index 000000000000..30d6b1e71a3e
--- /dev/null
+++ b/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file-1.20.patch
@@ -0,0 +1,16 @@
+--- cmd_app.cpp.old 2009-01-31 21:23:30.000000000 +0100
++++ cmd_app.cpp 2009-01-31 21:25:48.000000000 +0100
+@@ -88,7 +88,12 @@
+ _tsearchenv_s("PK2DeviceFile.dat", "PATH", tempString);
+ if (_tcslen(tempString) < 17)
+ {
+- _tcsncpy_s(tempString, "PK2DeviceFile.dat", 17);
++ // Try /usr/share/pk2 first
++ _tcsncpy_s(tempString, "/usr/share/pk2/PK2DeviceFile.dat", 32);
++
++ if(access(tempString, 0))
++ // Well, that didn't work, default to the current directory
++ _tcsncpy_s(tempString, "PK2DeviceFile.dat", 17);
+ }
+ }
+ if (!PicFuncs.ReadDeviceFile(tempString))
diff --git a/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch b/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch
new file mode 100644
index 000000000000..448fecfca935
--- /dev/null
+++ b/dev-embedded/pk2cmd/files/pk2cmd-add-share-dir-for-dev-file.patch
@@ -0,0 +1,17 @@
+--- cmd_app.cpp.bak 2008-07-11 15:49:56.000000000 -0400
++++ cmd_app.cpp 2008-09-20 23:18:17.000000000 -0400
+@@ -63,7 +63,13 @@
+ _tsearchenv_s("PK2DeviceFile.dat", "PATH", tempString);
+ if (_tcslen(tempString) < 17)
+ {
+- _tcsncpy_s(tempString, "PK2DeviceFile.dat", 17);
++ // Try /usr/share/pk2 first
++ _tcsncpy_s(tempString, "/usr/share/pk2/PK2DeviceFile.dat", 32);
++
++ if(access(tempString, 0))
++ // Well, that didn't work, default to the current directory
++ _tcsncpy_s(tempString, "PK2DeviceFile.dat", 17);
++
+ //_tcsncpy_s(tempString, "C:\\PICkit_2\\pk2cmd\\debug\\PK2DeviceFile.dat", 42);
+ //printf("DEBUG DEVICE FILE SETTING!!!!\n");
+ }
diff --git a/dev-embedded/pk2cmd/metadata.xml b/dev-embedded/pk2cmd/metadata.xml
new file mode 100644
index 000000000000..964d281fdb13
--- /dev/null
+++ b/dev-embedded/pk2cmd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+<maintainer>
+ <email>josejx@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+This application allows the use of the PICKit2 PIC programming device.
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild b/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild
new file mode 100644
index 000000000000..f18e20bdf602
--- /dev/null
+++ b/dev-embedded/pk2cmd/pk2cmd-1.20.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An application for working with the Microchip PicKit2 PIC programmer"
+HOMEPAGE="http://www.microchip.com/pickit2"
+SRC_URI="http://ww1.microchip.com/downloads/en/DeviceDoc/${PN}v${PV}LinuxMacSource.tar.gz"
+
+LICENSE="MicroChip-PK2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ppc64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}v${PV}LinuxMacSource
+
+src_prepare() {
+ # Patch adds /usr/share/pk2 to the default search for the device file
+ epatch "${FILESDIR}/${PN}-add-share-dir-for-dev-file-${PV}.patch"
+
+ # Fix up the Makefile
+ sed \
+ -e 's:#TARGET=linux:TARGET=linux:' \
+ -e 's:DBG=-O2:DBG=:' \
+ -e 's:^CFLAGS=:CFLAGS+=:' \
+ -e 's:^LDFLAGS=:LDFLAGS+=:' \
+ -e 's:^LIBUSB=/usr/local:LIBUSB=/usr:' \
+ -e "s:^CC=g++::" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)"
+}
+
+src_install() {
+ # Copy the device files and PicKit2 OS
+ insinto "/usr/share/pk2"
+ doins PK2DeviceFile.dat PK2V023200.hex
+ # Install the program
+ dobin pk2cmd
+ # Install the documentation
+ dodoc ReadmeForPK2CMDLinux2-6.txt usbhotplug.txt
+}