summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/ponyprog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/ponyprog')
-rw-r--r--dev-embedded/ponyprog/Manifest1
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-2.07a-gcc43.patch57
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-2.07c-build.patch45
-rw-r--r--dev-embedded/ponyprog/metadata.xml8
-rw-r--r--dev-embedded/ponyprog/ponyprog-2.07c-r1.ebuild63
5 files changed, 174 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/Manifest b/dev-embedded/ponyprog/Manifest
new file mode 100644
index 000000000000..724cb469f941
--- /dev/null
+++ b/dev-embedded/ponyprog/Manifest
@@ -0,0 +1 @@
+DIST Pony_Prog2000-2.07c.tar.gz 653300 SHA256 c9387e479a953a1b9aabbdaca31c90e65c8557db62bac21bd959cff346fa825e SHA512 33cd14fa8283ce8af8265a48df7d960c7c2779551d0f204f6728a9e1e54204f52ea608c4e6090dc56f7634a02abd9bb960230f75a3a9716b1639708a57c31809 WHIRLPOOL 64650b85c31f6982fed0aa5519f42e0b2d451184ecbfa0f4f9cb45996ad37675b05ed4f7d405d1462a291b6601dff926b0a51e8accc17f54bfdf92665882aa78
diff --git a/dev-embedded/ponyprog/files/ponyprog-2.07a-gcc43.patch b/dev-embedded/ponyprog/files/ponyprog-2.07a-gcc43.patch
new file mode 100644
index 000000000000..f93da01d646c
--- /dev/null
+++ b/dev-embedded/ponyprog/files/ponyprog-2.07a-gcc43.patch
@@ -0,0 +1,57 @@
+http://bugs.gentoo.org/227503
+
+--- a/v/includex/v/vpsdc.h
++++ b/v/includex/v/vpsdc.h
+@@ -14,7 +14,9 @@
+
+ #include <v/vdc.h>
+ #include <v/vprinter.h>
+-#include <fstream.h>
++#include <fstream>
++
++using namespace std;
+
+ class vPostScriptDC : public vDC
+ {
+--- a/v/includex/v/vpsprntr.h
++++ b/v/includex/v/vpsprntr.h
+@@ -14,7 +14,7 @@
+
+ #include <v/v_defs.h>
+ #include <v/vmodald.h>
+-#include <fstream.h>
++#include <fstream>
+
+ #define vPaperLetter 0
+ #define vPaperLegal 1
+@@ -31,6 +31,8 @@
+ #define vPaperQuarto 12
+ #define vPaper10x14 13
+
++using namespace std;
++
+ #define vPaperDefault vPaperLetter // Index to default paper
+
+ class vPSPrinter : public vModalDialog
+--- a/v/srcx/vpsprntr.cxx
++++ b/v/srcx/vpsprntr.cxx
+@@ -103,7 +103,7 @@ static unsigned char prompt_bits[] = {
+ _height = PaperHeights[_paperType];
+ _portrait = 1;
+ _useColor = 0;
+- _pstream = 0;
++ vPSPrinter::_pstream = 0;
+
+ ++_instances; // bump reference counter
+ }
+--- a/rs232int.cpp
++++ b/rs232int.cpp
+@@ -145,7 +145,7 @@ int RS232Interface::OpenSerial(int no)
+ snprintf(lockname, MAXPATH, LOCK_DIR "/LCK..ttyS%d", no);
+ UserDebug1(UserApp2, "RS232Interface::OpenSerial() now lock the device %s\n", lockname);
+
+- fd = open ((const char *)lockname,O_RDWR|O_EXCL|O_CREAT);
++ fd = open ((const char *)lockname,O_RDWR|O_EXCL|O_CREAT,0664);
+ if (fd < 0)
+ {
+ fd = open ((const char *)lockname,O_RDONLY);
diff --git a/dev-embedded/ponyprog/files/ponyprog-2.07c-build.patch b/dev-embedded/ponyprog/files/ponyprog-2.07c-build.patch
new file mode 100644
index 000000000000..cc29d2f1060e
--- /dev/null
+++ b/dev-embedded/ponyprog/files/ponyprog-2.07c-build.patch
@@ -0,0 +1,45 @@
+Fix parallel make and respect CC, CXX and LDFLAGS
+
+http://bugs.gentoo.org/282244
+http://bugs.gentoo.org/317767
+
+--- Makefile
++++ Makefile
+@@ -331,8 +331,8 @@
+
+ prps: $(PRPS)
+
+-$(PROG): $(OBJS)
+- $(CXX) -o $@ $(OBJS) $(LDFLAGS)
++$(PROG): $(OBJS) vlib
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(LIBDIR) $(LIBS)
+
+ %.o: %.cpp
+ $(CXX) $(CFLAGS) -c $< -o $@
+--- v/Config.mk
++++ v/Config.mk
+@@ -40,8 +40,6 @@
+ #---------------------------------------------------------------------
+ #CC = gcc
+ #CXX = g++
+-CC = gcc-3.4
+-CXX = g++-3.4
+
+ #---------------------------------------------------------------------
+ # VPATH for dependencies on header files
+@@ -302,5 +300,3 @@
+ #---------------------------------------------------------------------
+ # LINK/LOAD options
+ #---------------------------------------------------------------------
+-LDFLAGS = $(LIBDIR) $(LIBS)
+-
+--- v/srcx/Makefile
++++ v/srcx/Makefile
+@@ -142,7 +142,6 @@
+ vprogrsc.h vsliderc.h vtextinc.h vlistc.h vcomboc.h vtextc.h \
+ vcolor.h vpen.h vclabelc.h vspinc.h
+
+- cd iconed ; $(MAKE) ARCH=$@ ; cd ..
+
+
+ #xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
diff --git a/dev-embedded/ponyprog/metadata.xml b/dev-embedded/ponyprog/metadata.xml
new file mode 100644
index 000000000000..2556689d33b3
--- /dev/null
+++ b/dev-embedded/ponyprog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-embedded</herd>
+ <upstream>
+ <remote-id type="sourceforge">ponyprog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/ponyprog/ponyprog-2.07c-r1.ebuild b/dev-embedded/ponyprog/ponyprog-2.07c-r1.ebuild
new file mode 100644
index 000000000000..1828857b3d8f
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-2.07c-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Serial device programmer"
+HOMEPAGE="http://www.lancos.com/ppwin95.html"
+SRC_URI="mirror://sourceforge/${PN}/Pony_Prog2000-${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-misc/xdg-utils"
+DEPEND="${RDEPEND}
+ || ( media-gfx/graphicsmagick[imagemagick] media-gfx/imagemagick )"
+
+S="${WORKDIR}/PonyProg2000-${PV}"
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O2::' v/Config.mk || die
+ sed -i -e '/include.*<asm\/io.h>/s:asm:sys:' *.cpp || die
+ sed -i -e 's/netscape/xdg-open/' e2cmdw.cpp || die
+
+ convert ponyprog.ico ponyprog.png
+
+ epatch \
+ "${FILESDIR}/${PN}-2.07a-gcc43.patch" \
+ "${FILESDIR}/${PN}-2.07c-build.patch"
+ epatch_user
+}
+
+src_compile() {
+ tc-export CC CXX
+ # most of build is C++, but it uses CFLAGS
+ CFLAGS="${CXXFLAGS}" emake HOMEV="${S}/v"
+}
+
+src_install() {
+ dobin bin/ponyprog2000
+ keepdir /var/lock/uucp
+ fowners uucp:uucp /var/lock/uucp
+ fperms 755 /var/lock/uucp
+ doicon ponyprog.png
+ make_desktop_entry ponyprog2000 PonyProg2000 ponyprog
+}
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}