summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-09 00:37:21 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-09 00:37:21 -0400
commit5347a77f5523357d4ea00c8deb1cb25745787cea (patch)
tree09f00dce0b9fa80a6af199384a8f6344247e10da /dev-embedded/u-boot-tools
parentnet-analyzer/metasploit: fixes for live, not working yet but this is a huge c... (diff)
downloadgentoo-5347a77f5523357d4ea00c8deb1cb25745787cea.tar.gz
gentoo-5347a77f5523357d4ea00c8deb1cb25745787cea.tar.bz2
gentoo-5347a77f5523357d4ea00c8deb1cb25745787cea.zip
dev-embedded/u-boot-tools: version bump to 2017.05
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2017.05.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index c11585a05a42..23ef9afa2a33 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -2,3 +2,4 @@ DIST u-boot-2016.03.tar.bz2 11076762 SHA256 e49337262ecac44dbdeac140f2c6ebd1eba3
DIST u-boot-2016.07.tar.bz2 11506848 SHA256 974fb7225c0af6a721307631f66b81e20dbda82a4d7cc32aba2a625727231253 SHA512 fa76dbd7e654ff9e4b3166162be6c0a77ecf2eb2a952b4865df3c818ebcdca7e2bb75e5ba19bf0346000c3d185888552193bb74510b115426cfe444b78efd3ef WHIRLPOOL 066019af0e8fd04d53569ebd001309238514daa757be6cc50db6d4544f34d0c720ff420811d44d88af6028d02dfb02667e44d8d1abb23bb364baff46c5a26a9f
DIST u-boot-2016.09.01.tar.bz2 11783287 SHA256 95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb SHA512 aa503acb1ce4f64a936fbc1292e80c54fe334fcfb1a0da412a755f9a56a24993178ad1a5b8a51f777388d8ce5a62b0626bb5fead503f9b118f7d9f3f1a7c07b7 WHIRLPOOL 35b6ecedcdf99eabfddc90157b1998be1732fbdf46b4ca1221f8fb95e47d6e5fce7725d6b72d04b973f05267b31b3fd9d9beadba9d77e3d4dfc1c0b09d396957
DIST u-boot-2016.11.tar.bz2 12019669 SHA256 45813e6565dcc0436abe6752624324cdbf5f3ac106570d76d32b46ec529bcdc8 SHA512 d393b2aa4114a6de7f990efe370891376c934a1cfac9530c3bc44f988e7f2c9f0ec26653e3275c72a0a1c2f4b44fcd0afe8394c9ae3ca93fee1c689d870c063d WHIRLPOOL f9a7837cac2b7b4e1395350a9670e438396818bcb80baebbb9a65ebe739914319fa3e076c288bb3f10ffad0f954336a6a18ea5611824f7f05d7a1518bb65cdad
+DIST u-boot-2017.05.tar.bz2 11938152 SHA256 c8373949d7f0de1059e507b83a655d4cea539f75dc66ccdbb27adbd38d83095e SHA512 be270f9242a72b05463092a022bbabd54996762de1ff23bf7575124ac02e62f49572a4e2f6f571a5019047d40027e56e35593b5cc373c4a5a39b100c3377ba93 WHIRLPOOL 1e17bad773db4183cf3a290fd93c11f54cb50880cf608d43cb8e9c2de4724c6cdde97ba1e06dcc61a35d430c43872f33b393f9c973445ce80265a3d14d8af0b6
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2017.05.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2017.05.ebuild
new file mode 100644
index 000000000000..1a32e2433fa0
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2017.05.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+ emake defconfig
+ emake \
+ HOSTSTRIP=: \
+ STRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools || die
+ dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}"/doc/mkimage.1
+}