summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-02-28 20:20:56 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-02-28 20:20:56 +0100
commit67946bcd2c6027ed9753ad01aecb2961451d8b8c (patch)
treee98f0e0799ed047a7947e01d150b16f86732eec1 /dev-embedded/u-boot-tools
parentdev-libs/tree-sitter: Stabilize 0.20.2-r1 amd64, #834133 (diff)
downloadgentoo-67946bcd2c6027ed9753ad01aecb2961451d8b8c.tar.gz
gentoo-67946bcd2c6027ed9753ad01aecb2961451d8b8c.tar.bz2
gentoo-67946bcd2c6027ed9753ad01aecb2961451d8b8c.zip
dev-embedded/u-boot-tools: drop 2021.07
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2021.07.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index 0dd52ccff0a0..d16e492eb34b 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -1,3 +1,2 @@
-DIST u-boot-2021.07.tar.bz2 17275746 BLAKE2B 1a209a604e0f30264781a14ca855bbb777e8f1c031de60d28de397084fc9bfc4a3771ad00ec22f5cdcfa721f22707a533b9b59004ac0b107df927f23dc5ab0a6 SHA512 210b206a4626feb0985580d9448a97b499b09bf9b9313ca847a66624785e9e9b0fae8f2e329acd344f5f75cb722d2093dd0ee394311ddd1fde05e400ee71a24d
DIST u-boot-2021.10.tar.bz2 17358295 BLAKE2B 2471e31236ae24778b985b8e7a032fe2d480e935e9c5ee77a6aff4821c61f7fb8b3d64f9f964d62d0c076e8ac526f1b9c19f7fa1a974f4665737ab0bfd950d03 SHA512 be5be1c9a54b270307a04177d5577a21c57a02b307bf8b63d0fa2655d1f025c7ce010dca6a1f7f60d4e639c2e6fb6f0a292a2e5d190f1fad478eb12dd786c9da
DIST u-boot-2022.01.tar.bz2 17449627 BLAKE2B 574f9d248a8c19aa20b1b16cb55bb201d6c1ab2162da3f8789d39286a4f4a5a76b772d4a49c17e5572ff69f489d1d6fdc02d6e8f67a8bf6c50159b1a41e7c81d SHA512 d83c62bd8f0f51664d2aca329a3ce1379cfd1dfff439dccd6cfc2cb33cfef89a2b01855c97716f591b5550bfdf99e2f3aef7efa33f2e7834c820648f9eef3825
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2021.07.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2021.07.ebuild
deleted file mode 100644
index 92b7d18e73fb..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2021.07.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-MY_P="u-boot-${PV/_/-}"
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="https://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="https://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 ~riscv x86"
-IUSE="envtools"
-
-RDEPEND="dev-libs/openssl:="
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i 's:\bpkg-config\b:${PKG_CONFIG}:g' \
- scripts/kconfig/{g,m,n,q}conf-cfg.sh \
- scripts/kconfig/Makefile \
- tools/Makefile || die
-}
-
-src_configure() {
- tc-export AR BUILD_CC CC PKG_CONFIG
-}
-
-src_compile() {
- # Unset a few KBUILD variables. Bug #540476
- unset KBUILD_OUTPUT KBUILD_SRC
-
- local myemakeargs=(
- V=1
- AR="${AR}"
- CC="${CC}"
- HOSTCC="${BUILD_CC}"
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)'
- HOSTLDFLAGS="${LDFLAGS}"
- )
-
- emake "${myemakeargs[@]}" tools-only_defconfig
-
- emake "${myemakeargs[@]}" \
- NO_SDL=1 \
- HOSTSTRIP=: \
- STRIP=: \
- CONFIG_ENV_OVERWRITE=y \
- $(usex envtools envtools tools-all)
-}
-
-src_test() { :; }
-
-src_install() {
- cd tools || die
-
- if ! use envtools; then
- dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
- fi
-
- dobin env/fw_printenv
-
- dosym fw_printenv /usr/bin/fw_setenv
-
- insinto /etc
- doins env/fw_env.config
-
- doman ../doc/mkimage.1
-}