summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 18:25:38 +0000
committerSam James <sam@gentoo.org>2021-01-27 18:25:43 +0000
commit6f1bc5344dd6e0482771040b604299c668786dfa (patch)
tree711c93345b0b935ee601a0ec8ee3bc0a1a6894de /dev-embedded
parentdev-embedded/libftdi: fix tests w/o libftdi installed (diff)
downloadgentoo-6f1bc5344dd6e0482771040b604299c668786dfa.tar.gz
gentoo-6f1bc5344dd6e0482771040b604299c668786dfa.tar.bz2
gentoo-6f1bc5344dd6e0482771040b604299c668786dfa.zip
dev-embedded/libftdi: fix pkgconfig files with USE=cxx
Closes: https://bugs.gentoo.org/766818 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/libftdi/libftdi-1.5-r1.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-embedded/libftdi/libftdi-1.5-r1.ebuild b/dev-embedded/libftdi/libftdi-1.5-r1.ebuild
index 22e90fb4ca69..358cc5cf673c 100644
--- a/dev-embedded/libftdi/libftdi-1.5-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.5-r1.ebuild
@@ -68,6 +68,13 @@ src_test() {
src_install() {
cmake_src_install
+ # Fix up pkgconfig files
+ # bug #766818
+ if use cxx ; then
+ sed -i -e "s/libftdipp1/libftdi1/" "${ED}"/usr/lib64/pkgconfig/libftdi1.pc || die
+ sed -i -e "s/libftdi1/libftdipp1/" "${ED}"/usr/lib64/pkgconfig/libftdipp1.pc || die
+ fi
+
use python && python_optimize
dodoc AUTHORS ChangeLog README TODO