summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-02-04 16:39:41 +0100
committerSam James <sam@gentoo.org>2021-02-12 16:20:32 +0000
commitd3923ca62bf43b3b6f12cdedc28e9d488a44c4ce (patch)
tree17054b1673b296ffd52074169c1d1120d7bc23b8 /dev-embedded
parentmedia-libs/libavif: drop 0.8.3 version (diff)
downloadgentoo-d3923ca62bf43b3b6f12cdedc28e9d488a44c4ce.tar.gz
gentoo-d3923ca62bf43b3b6f12cdedc28e9d488a44c4ce.tar.bz2
gentoo-d3923ca62bf43b3b6f12cdedc28e9d488a44c4ce.zip
dev-embedded/esptool: remove old
remove esptool-2.8 esptool-2.8-r1 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/19321 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esptool/esptool-2.8-r1.ebuild41
-rw-r--r--dev-embedded/esptool/esptool-2.8.ebuild37
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-embedded/esptool/esptool-2.8-r1.ebuild b/dev-embedded/esptool/esptool-2.8-r1.ebuild
deleted file mode 100644
index b5059f85d948..000000000000
--- a/dev-embedded/esptool/esptool-2.8-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} ) # apps work with 3_9 but test depend is not fulfilled
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/ecdsa[${PYTHON_MULTI_USEDEP}]
- dev-python/pyaes[${PYTHON_MULTI_USEDEP}]
- >=dev-python/pyserial-3.0[${PYTHON_MULTI_USEDEP}]
- ')
-"
-BDEPEND="
- test? ( $(python_gen_cond_dep 'dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]') )
-"
-
-src_prepare() {
- rm -rf pyaes/ ecdsa/ || die "unable to remove bundled modules"
- default
-}
-
-python_test() {
- ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
-}
diff --git a/dev-embedded/esptool/esptool-2.8.ebuild b/dev-embedded/esptool/esptool-2.8.ebuild
deleted file mode 100644
index 5bcb03d5fe71..000000000000
--- a/dev-embedded/esptool/esptool-2.8.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- test? ( ${RDEPEND}
- dev-python/pyelftools[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
-}