summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2019-05-19 03:20:00 +0200
committerRafael Martins <rafaelmartins@gentoo.org>2019-05-19 03:20:07 +0200
commite1e437bdb6f2238d54227bf48bb437c1c3b4c854 (patch)
tree57c4ad99aa3c2a7adb6bdf35d49c6da09c0188cd /dev-embedded
parentsys-kernel/linux-firmware: fix use flag function (diff)
downloadgentoo-e1e437bdb6f2238d54227bf48bb437c1c3b4c854.tar.gz
gentoo-e1e437bdb6f2238d54227bf48bb437c1c3b4c854.tar.bz2
gentoo-e1e437bdb6f2238d54227bf48bb437c1c3b4c854.zip
dev-embedded/nodemcu-uploader: new package
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Rafael Martins <rafaelmartins@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/nodemcu-uploader/Manifest1
-rw-r--r--dev-embedded/nodemcu-uploader/metadata.xml15
-rw-r--r--dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-embedded/nodemcu-uploader/Manifest b/dev-embedded/nodemcu-uploader/Manifest
new file mode 100644
index 000000000000..259ab525dfac
--- /dev/null
+++ b/dev-embedded/nodemcu-uploader/Manifest
@@ -0,0 +1 @@
+DIST nodemcu-uploader-0.4.3.tar.gz 10034 BLAKE2B 2912d2d4130700fdd0a5145d7aa2b4d9f5742b85a9d0675da8a25a8e02812247928345661c69eadba00c41d33faad8def70ac7c3960794ca418875b942bb255f SHA512 bed8291cceea0f37b914fb45a409a6c259b32c325b09b71338382b29870591ce2003c235a2c231d8ffc0a3600d51a5f89acad1fa5a6fd01fe96fdcaaa55266a0
diff --git a/dev-embedded/nodemcu-uploader/metadata.xml b/dev-embedded/nodemcu-uploader/metadata.xml
new file mode 100644
index 000000000000..2c9f7d996763
--- /dev/null
+++ b/dev-embedded/nodemcu-uploader/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <longdescription lang="en">
+ A simple tool for uploading files to the filesystem of an ESP8266
+ running NodeMCU as well as some other useful commands.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">nodemcu-uploader</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3.ebuild b/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3.ebuild
new file mode 100644
index 000000000000..d9b5adfc1a0e
--- /dev/null
+++ b/dev-embedded/nodemcu-uploader/nodemcu-uploader-0.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple tool for uploading files to the filesystem of an ESP8266 running NodeMCU"
+HOMEPAGE="https://github.com/kmpm/nodemcu-uploader"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/wrapt-1.10.10[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-2.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RESTRICT="test" # tests are not uploaded to pypi
+
+python_test() {
+ esetup.py test || die
+}