summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-06-06 23:17:10 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-06-07 23:20:34 +0100
commitd11c22db4e478d917be4e30a4d11d56d2684c6f8 (patch)
treed26fc0e5087f41574a04c55898c2cb10ce4af49f /dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
parentdev-erlang/p1_mysql: Add new package (diff)
downloadgentoo-d11c22db4e478d917be4e30a4d11d56d2684c6f8.tar.gz
gentoo-d11c22db4e478d917be4e30a4d11d56d2684c6f8.tar.bz2
gentoo-d11c22db4e478d917be4e30a4d11d56d2684c6f8.zip
dev-erlang/p1_oauth2: Add new package
It is debundled from net-im/ejabberd-16.04 and therefore inherits keywords from ejabberd: ~amd64, ~arm, ~ppc and ~x86. ~ia64 and ~sparc are not inherited because other dependency is missing these keywords and there's no chance it can get them any time soon. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild')
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
new file mode 100644
index 000000000000..33305964fc01
--- /dev/null
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang OAuth 2.0 implementation"
+HOMEPAGE="https://github.com/processone/p1_oauth2"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.3
+ >=dev-erlang/proper-1.1_p20150814
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_remove_deps rebar.test.config
+}
+
+src_test() {
+ erebar -C rebar.test.config compile eunit
+}