summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-12-10 10:03:30 +0100
committerFlorian Schmaus <flow@gentoo.org>2021-12-10 14:03:42 +0100
commitd642086b21113226cc4564941b98a22856755f26 (patch)
treec8d7ee103d0a2a289a5f9d8192582777ac9bec9a /dev-erlang/p1_oauth2
parentdev-erlang/p1_mysql: add 1.0.19 (diff)
downloadgentoo-d642086b21113226cc4564941b98a22856755f26.tar.gz
gentoo-d642086b21113226cc4564941b98a22856755f26.tar.bz2
gentoo-d642086b21113226cc4564941b98a22856755f26.zip
dev-erlang/p1_oauth2: add 0.6.10
Bug: https://bugs.gentoo.org/810886 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-erlang/p1_oauth2')
-rw-r--r--dev-erlang/p1_oauth2/Manifest1
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.10.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-erlang/p1_oauth2/Manifest b/dev-erlang/p1_oauth2/Manifest
index fece05f788b1..7895b78f4ba5 100644
--- a/dev-erlang/p1_oauth2/Manifest
+++ b/dev-erlang/p1_oauth2/Manifest
@@ -1,2 +1,3 @@
+DIST p1_oauth2-0.6.10.tar.gz 214205 BLAKE2B 228a616473ff9c6d7ecd5f7aedad3a971fca2b811938382160c9fe24dc949b52c7c1b023343833cc218dc3269ae742a5617ecf6f831fb93616a200e6169eaecc SHA512 a32fdd8e9c85b1b5729f2dadc3f2f6c84479048d94fc41dbf241baac41c3ccd47b12b9e24dabbaf832ac9182f47673db068c55f92d1e750dba42309c0f8d0c25
DIST p1_oauth2-0.6.6.tar.gz 213866 BLAKE2B 2b7ff13697658c6ab31a2cab60100758d965ae0f3cbeb878539e42210e54e7cf33a458c645e432790f79ba3fa92ab35a5d6d6136edc14369ac6d8872e16d7f69 SHA512 9680bc96608bc486165d5f77cf6e92e5f9257e0dbea718c739563556c2b485f67152dcd99cbe228addd34b33b2dd6cc9eacc3827f269412f705acd14b2522952
DIST p1_oauth2-0.6.9.tar.gz 214329 BLAKE2B 8c8d0d9186d54099834a1b150699940e19dc2de7c194f96169fd5bb518fd515688071405b8f238ecfd91fffe1d42d22ddf70fe5850bd72cc80dade384fa94c46 SHA512 30f912e82c035bbaec6dd1b25908426f587a9fc8f401d47ac95d508b426d3d5ea3f77c798dc8c6d4e171dc309cc18748629615671a9fee0fc01f3328133427fe
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.10.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.10.ebuild
new file mode 100644
index 000000000000..27da5be02667
--- /dev/null
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rebar
+
+DESCRIPTION="Erlang OAuth 2.0 implementation"
+HOMEPAGE="https://github.com/processone/p1_oauth2"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.7
+ >=dev-erlang/proper-1.3
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+}