summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2021-04-08 08:17:24 +0200
committerSam James <sam@gentoo.org>2021-06-01 09:35:20 +0000
commit97987bcf5db3be4d7122cbd0de3d42ad27907d94 (patch)
treea3871e1a4a624a6b9e070b6d0cd0235ae3fc7a24 /dev-erlang/p1_utils
parentrebar.eclass: add support for EAPI 7 (diff)
downloadgentoo-97987bcf5db3be4d7122cbd0de3d42ad27907d94.tar.gz
gentoo-97987bcf5db3be4d7122cbd0de3d42ad27907d94.tar.bz2
gentoo-97987bcf5db3be4d7122cbd0de3d42ad27907d94.zip
dev-erlang/p1_utils: add 1.0.22
Closes: https://bugs.gentoo.org/766686 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-erlang/p1_utils')
-rw-r--r--dev-erlang/p1_utils/Manifest1
-rw-r--r--dev-erlang/p1_utils/p1_utils-1.0.22.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-erlang/p1_utils/Manifest b/dev-erlang/p1_utils/Manifest
index 6807f6cc9361..19aff78e36f2 100644
--- a/dev-erlang/p1_utils/Manifest
+++ b/dev-erlang/p1_utils/Manifest
@@ -1,2 +1,3 @@
DIST p1_utils-1.0.19.tar.gz 63649 BLAKE2B 0fe55dc6fdd436b5e77ad02bba923afe17cbac71374aee53a752739a93bb1d07c1ad85327e7c198cc442722a57928b750efd6d35f4a30cacb923045dd39e57c5 SHA512 bcc4b2abcd7d783d307e53b154da22bb548be05dd0636e455485423e8ab74acf097f1b3be58989dcdd5cc178746777b3062c332e73d2d9e4771973aa6e523376
DIST p1_utils-1.0.20.tar.gz 63739 BLAKE2B 7bad679e526d934a06b8ad8f049965cdba713f168e2232e30389dd0906ceb0cd4d311daa5247ba5b5dd3d6155d59c64dd77510cfa15d6995a91201f62989b7a1 SHA512 cf389039f4bac9a62379c3f33c4820b3ea13c4929f8db20ea0b491eae455f4d69a36567a30d2800aad6d46837340040a2a30cc3cb9216c24f15f3e48524cc7b8
+DIST p1_utils-1.0.22.tar.gz 64860 BLAKE2B 59b556f8d3662c60786b2723c163c8a34f6ffe8f0507141ea0a7ed7214fc00a6b74d840e115bd5fdc97b7382f510b05c1c29ef794299a6687990fffceb785eb2 SHA512 f9e0106ebb6bc7a63080a38ec59fb417fe9443dd53e801bed48ad26a112c0e6b82dd1bc1a5a7930170f41151b44054d33f53c8372f8bc3d53e789e135d63d674
diff --git a/dev-erlang/p1_utils/p1_utils-1.0.22.ebuild b/dev-erlang/p1_utils/p1_utils-1.0.22.ebuild
new file mode 100644
index 000000000000..92233aa7c2ce
--- /dev/null
+++ b/dev-erlang/p1_utils/p1_utils-1.0.22.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang utility modules from ProcessOne"
+HOMEPAGE="https://github.com/processone/p1_utils"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1:="
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )