summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/cegui/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/cegui/files')
-rw-r--r--dev-games/cegui/files/cegui-0.6.2b-dups.patch12
-rw-r--r--dev-games/cegui/files/cegui-0.6.2b-gcc43.patch10
-rw-r--r--dev-games/cegui/files/cegui-0.6.2b-gcc46.patch10
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-games/cegui/files/cegui-0.6.2b-dups.patch b/dev-games/cegui/files/cegui-0.6.2b-dups.patch
new file mode 100644
index 000000000000..a4d80c4347dc
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.6.2b-dups.patch
@@ -0,0 +1,12 @@
+diff -Naur _orig_CEGUI-0.6.2/include/elements/Makefile.am CEGUI-0.6.2/include/elements/Makefile.am
+--- _orig_CEGUI-0.6.2/include/elements/Makefile.am 2008-01-02 15:26:05.000000000 +0100
++++ CEGUI-0.6.2/include/elements/Makefile.am 2010-07-11 13:12:16.786338068 +0200
+@@ -21,8 +21,6 @@
+ CEGUIItemListBaseProperties.h \
+ CEGUIItemListbox.h \
+ CEGUIItemListboxProperties.h \
+- CEGUIListHeader.h \
+- CEGUIListHeaderProperties.h \
+ CEGUIListbox.h \
+ CEGUIListboxItem.h \
+ CEGUIListboxProperties.h \
diff --git a/dev-games/cegui/files/cegui-0.6.2b-gcc43.patch b/dev-games/cegui/files/cegui-0.6.2b-gcc43.patch
new file mode 100644
index 000000000000..09695626ceff
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.6.2b-gcc43.patch
@@ -0,0 +1,10 @@
+--- RendererModules/directfbRenderer/directfb-renderer.h
++++ RendererModules/directfbRenderer/directfb-renderer.h
+@@ -28,6 +28,7 @@
+ #include "CEGUIBase.h"
+ #include <directfb.h>
+
++#include <algorithm>
+ #include <vector>
+ #include <list>
+
diff --git a/dev-games/cegui/files/cegui-0.6.2b-gcc46.patch b/dev-games/cegui/files/cegui-0.6.2b-gcc46.patch
new file mode 100644
index 000000000000..88f8fccfc206
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.6.2b-gcc46.patch
@@ -0,0 +1,10 @@
+--- cegui/include/CEGUIString.h.old 2011-04-27 14:33:25.862856070 +0200
++++ cegui/include/CEGUIString.h 2011-04-27 14:33:49.780351908 +0200
+@@ -34,6 +34,7 @@
+ #include <string>
+ #include <string.h>
+ #include <stdexcept>
++#include <cstddef>
+
+ // Start of CEGUI namespace section
+ namespace CEGUI