summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-10-11 01:24:28 -0400
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-10-13 21:27:09 +0200
commitf928bd3c92fca93814668701654a174e52e2ae5a (patch)
treeca172ceed5ab7e4ecf6c829b8ed8cc31f75cabc2 /dev-games/clanlib
parentapp-admin/lsat: stable 0.9.7.1-r2 for ppc, bug #627222 (diff)
downloadgentoo-f928bd3c92fca93814668701654a174e52e2ae5a.tar.gz
gentoo-f928bd3c92fca93814668701654a174e52e2ae5a.tar.bz2
gentoo-f928bd3c92fca93814668701654a174e52e2ae5a.zip
dev-games/clanlib: Fix building with GCC-6
Closes: https://bugs.gentoo.org/596112 Closes: https://github.com/gentoo/gentoo/pull/5915 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/clanlib-0.8.1.ebuild3
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch16
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-games/clanlib/clanlib-0.8.1.ebuild b/dev-games/clanlib/clanlib-0.8.1.ebuild
index 0e13a37d97d2..dbd437a41db7 100644
--- a/dev-games/clanlib/clanlib-0.8.1.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -40,6 +40,7 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-gcc6.patch \
"${FILESDIR}"/${P}-libpng15.patch
}
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch
new file mode 100644
index 000000000000..95284c2de4ca
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch
@@ -0,0 +1,16 @@
+Bug: https://bugs.gentoo.org/596112
+
+--- a/Sources/Core/IOData/Generic/datafile_inputprovider.h
++++ b/Sources/Core/IOData/Generic/datafile_inputprovider.h
+@@ -142,9 +142,9 @@
+ void insert(const std::string &resource_id, int data_pos, int data_size)
+ {
+ cache.insert(
+- std::make_pair<std::string const, std::pair<int, int> >(
++ std::pair<std::string const, std::pair<int, int> >(
+ resource_id,
+- std::make_pair<int,int>(data_pos, data_size)));
++ std::pair<int,int>(data_pos, data_size)));
+ }
+
+ private: